http://mirror.centos.org/centos/7/virt/x86_64/kvm-common/repodata/b58d947530c09c958e0d78c2c9029ef1fbb4d341c68ce99e3b0133561ca70421-primary.sqlite.bz2: [Errno 14] HTTP Error 404 - Not Found"

Bug #1779642 reported by Quique Llorente on 2018-07-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
High
Quique Llorente

Bug Description

Runnig a noop change over tqe we get the following error:
http://logs.openstack.org/45/560445/77/check/tripleo-ci-centos-7-scenario004-multinode-oooq-container/02d4f13/logs/undercloud/home/zuul/overcloud_prep_containers.log.txt.gz

Running in fbf273cc5731\\n ---> 1e2b08e9f0c5\\nRemoving intermediate container fbf273cc5731\\nStep 4/10 : COPY yum_update.sh /tmp/\\n ---> bfe582520e9b\\nRemoving intermediate container 9a16d8ea04ad\\nStep 5/10 : COPY compare-package-json.py /tmp/\\n ---> 9b9b7f9aa88e\\nRemoving intermediate container 82bca7431885\\nStep 6/10 : COPY yum.repos.d /etc/\\n ---> a2c1d3652b54\\nRemoving intermediate container 406ca7fca1b4\\nStep 7/10 : COPY repos /\\n ---> 8220689015c7\\nRemoving intermediate container a13b3707467b\\nStep 8/10 : COPY host_packages.json /tmp/\\n ---> cb361ee2febe\\nRemoving intermediate container 7f78be20892c\\nStep 9/10 : RUN /tmp/yum_update.sh \\"gating-repo\\"\\n ---> Running in 5287baa4d982\\n\\n\\u001b[91m\\u001b[0m\\u001b[91m+ \'[\' -f /tmp/host_packages.json \']\'\\n\\u001b[0m\\u001b[91m+ /tmp/compare-package-json.py\\n\\u001b[0mpuppet-mistral-13.1.1-0.20180612101254.39f2929.el7 does not match host version 13.1.1-0.20180621214415.a00040d.el7\\n\\u001b[91m+ packages_for_update=\\n+ \'[\' -n gating-repo \']\'\\n+ packages_for_update=(\\"$(repoquery --disablerepo=\'*\' --enablerepo=$1 --qf %{NAME} -a)\\")\\n\\u001b[0m\\u001b[91m++ repoquery \'--disablerepo=*\' --enablerepo=gating-repo --qf \'%{NAME}\' -a\\n\\u001b[0m\\u001b[91mRepository delorean-master-build-deps is listed more than once in the configuration\\n\\u001b[0m\\u001b[91m+ yum -y update\\n\\u001b[0mLoaded plugins: fastestmirror, ovl, priorities\\n\\u001b[91mRepository delorean-master-build-deps is listed more than once in the configuration\\n\\u001b[0mDetermining fastest mirrors\\n\\u001b[91mhttp://mirror.centos.org/centos/7/virt/x86_64/kvm-common/repodata/b58d947530c09c958e0d78c2c9029ef1fbb4d341c68ce99e3b0133561ca70421-primary.sqlite.bz2: [Errno 14] HTTP Error 404 - Not Found\\n\\u001b[0m\\u001b[91mTrying other mirror.\\n\\u001b[0m\\u001b[91mTo address this issue please refer to the below wiki article \\n\\nhttps://wiki.centos.org/yum-errors\\n\\nIf above article doesn\'t help to resolve this issue please use https://bugs.centos.org/.\\n\\n\\u001b[0m\\u001b[91mhttp://mirror.centos.org/centos/7/virt/x86_64/kvm-common/repodata/b58d947530c09c958e0d78c2c9029ef1fbb4d341c68ce99e3b0133561ca70421-primary.sqlite.bz2: [Errno 14] HTTP Error 404 - Not Found\\n\\u001b[0m\\u001b[91mTrying other mirror.\\n\\u001b[0m\\u001b[91mhttp://mirror.centos.org/centos/7/virt/x86_64/kvm-common/repodata/b58d947530c09c958e0d78c2c9029ef1fbb4d341c68ce99e3b0133561ca70421-primary.sqlite.bz2: [Errno 14] HTTP Error 404 - Not Found\\nTrying other mirror.\\n\\u001b[0m\\u001b[91mhttp://mirror.centos.org/centos/7/virt/x86_64/kvm-common/repodata/b58d947530c09c958e0d78c2c9029ef1fbb4d341c68ce99e3b0133561ca70421-primary.sqlite.bz2: [Errno 14] HTTP Error 404 - Not Found\\nTrying other mirror.\\n\\u001b[0m\\u001b[91mhttp://mirror.centos.org/centos/7/virt/x86_64/kvm-common/repodata/b58d947530c09c958e0d78c2c9029ef1fbb4d341c68ce99e3b0133561ca70421-primary.sqlite.bz2: [Errno 14] HTTP Error 404 - Not Found\\nTrying other mirror.\\n\\u001b[0m\\u001b[91m\\n\\n One of the configured repositories failed (CentOS-7 - QEMU EV),\\n and yum doesn\'t have enough cached data to continue. At this point the only\\n safe thing yum can do is fail. There are a few ways to work \\"fix\\" this:\\n\\n 1. Contact the upstream for the repository and get them to fix the problem.\\n\\n 2. Reconfigure the baseurl/etc. for the repository, to point to a working\\n upstream. This is most often useful if you are using a newer\\n distribution release than is supported by the repository (and the\\n packages for the previous distribution release still work).\\n\\n 3. Run the command with the repository temporarily disabled\\n yum --disablerepo=centos-qemu-ev ...\\n\\n 4. Disable the repository permanently, so yum won\'t u

Quique Llorente (quiquell) wrote :

Unable to reproduce it at RDO cloud with reproducer-quickstart.sh

Changed in tripleo:
status: Triaged → Fix Released
status: Fix Released → Triaged
tags: removed: alert
Quique Llorente (quiquell) wrote :

Looks like we remove centos-qemu-ev repo in the host

sudo rm -rf '/etc/yum.repos.d/CentOS-OpenStack-*.repo' '/etc/yum.repos.d/CentOS-Ceph-*.repo' /etc/yum.repos.d/CentOS-QEMU-EV.repo

http://logs.openstack.org/45/560445/77/check/tripleo-ci-centos-7-scenario004-multinode-oooq-
container/02d4f13/logs/undercloud/home/zuul/repo_setup.log.txt.gz#_2018-07-02_08_22_43

But this is not done in the docker image.

Changed in tripleo:
importance: Critical → Medium
status: Triaged → In Progress
Changed in tripleo:
importance: Medium → Critical
importance: Critical → High

Reviewed: https://review.openstack.org/579803
Committed: https://git.openstack.org/cgit/openstack/ansible-role-tripleo-modify-image/commit/?id=a9055e351b31e3370fe2c868e45bda3bf1526460
Submitter: Zuul
Branch: master

commit a9055e351b31e3370fe2c868e45bda3bf1526460
Author: Quique Llorente <email address hidden>
Date: Tue Jul 3 10:15:23 2018 +0200

    Remove previous yum.repos.d to only used the custom ones

    There are some repos that are deactivated in the hosts
    but not deactivated in the docker images, like
    CentOS-QEMU-EV.repo, this patch remove the old repos dir
    to just use the the ones injected.

    Change-Id: I15284189fda16514f7ba70b95ab551d58eca7ab1
    Closes-Bug: 1779642

Changed in tripleo:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.