"AnsibleUndefinedVariable: 'container_build_id' is undefined"}"

Bug #1777896 reported by wes hayutin on 2018-06-20
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
tripleo
High
wes hayutin

Bug Description

quickstart.sh executed runs are currently broken due to a recent change

"fatal: [undercloud]: FAILED! => {"changed": false, "failed": true, "msg": "AnsibleUndefinedVariable: 'container_build_id' is undefined"}"

fix is incoming

tags: added: quickstart
Changed in tripleo:
status: New → Triaged
importance: Undecided → High
milestone: none → rocky-3
wes hayutin (weshayutin) on 2018-06-20
tags: added: alert
removed: quickstart

Fix proposed to branch: master
Review: https://review.openstack.org/576904

Changed in tripleo:
assignee: nobody → wes hayutin (weshayutin)
status: Triaged → In Progress
tags: added: quickstart
Quique Llorente (quiquell) wrote :

Reproduced with different variable fatal: [localhost -> localhost]: FAILED! => {"changed": false, "failed": true, "msg": "AnsibleUndefinedVariable: \"hostvars['undercloud']\" is undefined"}

Miguel Angel Ajo (mangelajo) wrote :

I wonder, why wasn't this detected by CI?.

Can we have some sort of CI job to invoke this in a way closer to what a normal user would do?

Changed in tripleo:
assignee: wes hayutin (weshayutin) → Quique Llorente (quiquell)
Changed in tripleo:
assignee: Quique Llorente (quiquell) → wes hayutin (weshayutin)
John Fulton (jfulton-org) wrote :

Started a oooq deployment with:

bash quickstart.sh --teardown all --release $RELEASE --nodes nodes.yaml --config config.yaml $VIRTHOST

but hit the error reported in this bug.

Applied changes from https://review.openstack.org/#/c/576904
in ~/.quickstart/usr/local/share/ansible/roles/ and then then ran:

bash quickstart.sh --tags 'undercloud-install,undercloud-post-install' --teardown none --retain-inventory --release $RELEASE --nodes nodes.yaml --config config.yaml $VIRTHOST

and undercloud installation was successful.

Change abandoned by wes hayutin (<email address hidden>) on branch: master
Review: https://review.openstack.org/576904
Reason: linting error, will restore

tags: removed: alert

Reviewed: https://review.openstack.org/576904
Committed: https://git.openstack.org/cgit/openstack/tripleo-quickstart-extras/commit/?id=2037e9a41540faa10f40f4fbbf3576f39a9c193a
Submitter: Zuul
Branch: master

commit 2037e9a41540faa10f40f4fbbf3576f39a9c193a
Author: Wes Hayutin <email address hidden>
Date: Wed Jun 20 12:14:00 2018 -0400

    set container variables when needed

    Only run container tasks when required to:
    1. prior to undercloud
    2. prior to overcloud-prep-containers
    3. prior to standalone deployment

    Closes-Bug: #1777896
    Change-Id: I50054a95500747972454305001d34c4c97b71e7f

Changed in tripleo:
status: In Progress → Fix Released
wes hayutin (weshayutin) on 2018-07-02
Changed in tripleo:
status: Fix Released → Triaged
Changed in tripleo:
status: Triaged → In Progress
wes hayutin (weshayutin) wrote :

Related Changes
18<openstackgerrit18> wes hayutin proposed openstack/tripleo-quickstart master: allow tq req to be installed w/o cache https://review.openstack.org/579381
18<openstackgerrit18> wes hayutin proposed openstack/tripleo-quickstart-extras master: ensure the container_build_id is set https://review.openstack.org/579382

Reviewed: https://review.openstack.org/579381
Committed: https://git.openstack.org/cgit/openstack/tripleo-quickstart/commit/?id=df55d3908d053b5b3a33d0dfa22ed7cbe65ea1b6
Submitter: Zuul
Branch: master

commit df55d3908d053b5b3a33d0dfa22ed7cbe65ea1b6
Author: Wes Hayutin <email address hidden>
Date: Sun Jul 1 12:37:41 2018 -0400

    allow tq req to be installed w/o cache

    When the user specifies --clean the pip
    cache dir should not be used.

    Related-Bug: #1777896
    Change-Id: I74c03ecaedaa8847c585814acf6249722b508dff

Flavio Percoco (flaper87) wrote :

I'm still getting this issue using latest trunk for both, extras and oooq:

TASK [undercloud-deploy : Write containers-prepare-parameter.yaml] *******************************************[27/1932]
task path: /root/.quickstart-shiftstack/usr/local/share/ansible/roles/undercloud-deploy/tasks/create-scripts.yml:96
Wednesday 04 July 2018 15:26:10 +0200 (0:00:05.990) 0:34:24.604 ********
fatal: [undercloud]: FAILED! => {"changed": false, "msg": "AnsibleUndefinedVariable: 'container_build_id' is undefined"
}

Yes, the reports of it being fixed were incorrect. Sorry man

https://review.openstack.org/#/c/579382/

On Wed, 4 Jul 2018 at 09:41 Flavio Percoco <email address hidden>
wrote:

> I'm still getting this issue using latest trunk for both, extras and
> oooq:
>
> TASK [undercloud-deploy : Write containers-prepare-parameter.yaml]
> *******************************************[27/1932]
> task path:
> /root/.quickstart-shiftstack/usr/local/share/ansible/roles/undercloud-deploy/tasks/create-scripts.yml:96
> Wednesday 04 July 2018 15:26:10 +0200 (0:00:05.990) 0:34:24.604
> ********
> fatal: [undercloud]: FAILED! => {"changed": false, "msg":
> "AnsibleUndefinedVariable: 'container_build_id' is undefined"
> }
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1777896
>
> Title:
> "AnsibleUndefinedVariable: 'container_build_id' is undefined"}"
>
> Status in tripleo:
> In Progress
>
> Bug description:
> quickstart.sh executed runs are currently broken due to a recent
> change
>
> "fatal: [undercloud]: FAILED! => {"changed": false, "failed": true,
> "msg": "AnsibleUndefinedVariable: 'container_build_id' is undefined"}"
>
> fix is incoming
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/tripleo/+bug/1777896/+subscriptions
>

Reviewed: https://review.openstack.org/579382
Committed: https://git.openstack.org/cgit/openstack/tripleo-quickstart-extras/commit/?id=839656067773ecf842208f0373750936e304db83
Submitter: Zuul
Branch: master

commit 839656067773ecf842208f0373750936e304db83
Author: Wes Hayutin <email address hidden>
Date: Sun Jul 1 12:43:49 2018 -0400

    ensure the container_build_id is set

    In locally run workflows the container_build_id is not set.
    Ensure the var is set properly and is echo'd to the console
    for transparency.

    Closes-Bug: #1777896
    Depends-On: I74c03ecaedaa8847c585814acf6249722b508dff
    Change-Id: I138471bf07476fa174eca315cf6e4330d1ea65fa

Changed in tripleo:
status: In Progress → Fix Released
Sorin Sbarnea (ssbarnea) wrote :

I seen same failure on:
TASK [undercloud-deploy : Write containers-prepare-parameter.yaml] *************

Sorin Sbarnea (ssbarnea) wrote :

Raised https://review.openstack.org/#/c/595782/ in order to avoid that failure too.

Change abandoned by Sorin Sbarnea (<email address hidden>) on branch: master
Review: https://review.openstack.org/595782
Reason: Aborting in favor of Bogdan's patch.

Sorin Sbarnea (ssbarnea) wrote :

I have the impression that I seen this again today on https://ci.centos.org/job/tripleo-quickstart-gate-master-delorean-quick-basic/6854/consoleFull

13:17:07 TASK [undercloud-deploy : Write containers-prepare-parameter.yaml] *************
13:17:07 task path: /home/jenkins/workspace/tripleo-quickstart-gate-master-delorean-quick-basic@2/usr/local/share/ansible/roles/undercloud-deploy/tasks/create-scripts.yml:96
13:17:07 Monday 03 September 2018 12:17:07 +0000 (0:00:07.025) 0:36:20.137 ******
13:17:10 fatal: [undercloud]: FAILED! => {"changed": false, "msg": "AnsibleUndefinedVariable: 'container_build_id' is undefined"}
13:17:10
13:17:10 PLAY RECAP *********************************************************************

Sorin Sbarnea (ssbarnea) on 2018-09-03
tags: added: alert

This issue was fixed in the openstack/tripleo-quickstart-extras 2.1.1 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers