when collect logs fails, reproducer script is not uploaded

Bug #1776164 reported by Bogdan Dobrelya on 2018-06-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Critical
Sagi (Sergey) Shnaidman

Bug Description

When the colllect CI logs fails, there are operations pending like creating a dump for the reproduce script and prolly more things to do.

10:25:57 AM GMT+3 - ykarel: bogdando, there is issue with collect logs:- https://logs.rdoproject.org/33/572533/5/openstack-check/gate-tripleo-ci-centos-7-ovb-3ctlr_1comp-featureset001-master/Z659cc00387184293b4d2ee28ad68cb8c/quickstart_collect_logs.txt.gz
10:25:60 AM GMT+3 -<ykarel> 'tempest_format' is undefined"
10:26:38 AM GMT+3 - quiquell: bogdando, ykarel: Yep, collect logs is failing and the reproducer is not dumped

Tags: ci Edit Tag help
Changed in tripleo:
importance: Undecided → Critical
milestone: none → rocky-3
tags: added: ci
yatin (yatinkarel) on 2018-06-11
description: updated

Fix proposed to branch: master
Review: https://review.openstack.org/574164

Changed in tripleo:
assignee: nobody → Sagi (Sergey) Shnaidman (sshnaidm)
status: New → In Progress

Caused by https://review.openstack.org/#/c/566527/ when injected undefined variable in docs generation part of logs collection.

summary: - when collect logs fails, remaining logic for the ci job gets interrupted
+ when collect logs fails, reproducer script is not uploaded

Reviewed: https://review.openstack.org/574164
Committed: https://git.openstack.org/cgit/openstack/tripleo-quickstart/commit/?id=fb900349aaf30b50cbc26846c3ea68306062d9f5
Submitter: Zuul
Branch: master

commit fb900349aaf30b50cbc26846c3ea68306062d9f5
Author: Sagi Shnaidman <email address hidden>
Date: Mon Jun 11 11:23:42 2018 +0300

    Fix logs by setting defaults for tempest_format

    Bug was introduced in https://review.openstack.org/#/c/566527/
    Set default value for tempest_format in logs collection role
    when it publishes docs.
    Closes-Bug: #1776164

    Change-Id: I25a73bbd3804cf013f38627ca3d742e3a6a2f5d1

Changed in tripleo:
status: In Progress → Fix Released

This issue was fixed in the openstack/tripleo-quickstart 2.1.1 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers