jobs running container updates fail because containers are trying to be pushed to docker.io

Bug #1772122 reported by Alex Schultz on 2018-05-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Critical
Alex Schultz

Bug Description

Failures due to https://review.openstack.org/#/c/528621/

http://logs.openstack.org/86/568986/2/check/tripleo-ci-centos-7-scenario000-multinode-oooq-container-updates/845a40e/logs/undercloud/home/zuul/overcloud_prep_containers.log.txt.gz#_2018-05-18_21_06_32

2018-05-18 21:06:31 | 2018-05-18 21:06:31,162 INFO: Running docker command: /usr/bin/docker commit -m automatic yum update --change CMD ["kolla_start"]
2018-05-18 21:06:31 | yum-update-13 docker.io/tripleomaster/centos-binary-haproxy:c06e315e87d6326f984bbbb038f7cdec9d1e187f_cd134cc0
2018-05-18 21:06:32 | 2018-05-18 21:06:32,058 INFO: Running docker command: /usr/bin/docker push docker.io/tripleomaster/centos-binary-haproxy:c06e315e87d6326f984bbbb038f7cdec9d1e187f_cd134cc0
2018-05-18 21:06:32 | 2018-05-18 21:06:32,261 ERROR: Failed running docker push for docker.io/tripleomaster/centos-binary-cron:c06e315e87d6326f984bbbb038f7cdec9d1e187f_cd134cc0
2018-05-18 21:06:32 | 2018-05-18 21:06:32,261 ERROR: denied: requested access to the resource is denied
2018-05-18 21:06:32 |
2018-05-18 21:06:32 | 2018-05-18 21:06:32,261 INFO: Removing container: yum-update-14
2018-05-18 21:06:32 | 2018-05-18 21:06:32,322 DEBUG: yum-update-14
2018-05-18 21:06:32 |

This was caused by a change in the overcloud_containers.yaml generation which resulted in a file that no longer referenced the local repository. The container update script does not honor the push_destination: setting.

Changed in tripleo:
assignee: nobody → Alex Schultz (alex-schultz)
status: Triaged → In Progress
tags: added: promotion-blocker
Emilien Macchi (emilienm) wrote :

Revert until we fix the root issue: https://review.openstack.org/#/c/569528

Reviewed: https://review.openstack.org/569528
Committed: https://git.openstack.org/cgit/openstack/tripleo-quickstart-extras/commit/?id=a17a676489a206fce5f30fa664e1cc97497ded85
Submitter: Zuul
Branch: master

commit a17a676489a206fce5f30fa664e1cc97497ded85
Author: Alex Schultz <email address hidden>
Date: Fri May 18 22:13:23 2018 +0000

    Revert "Run "overcloud container image prepare" only once"

    This reverts commit 445157148a46452c26ffa070e31b4da1c8e4503d.

    The containers update script does not handle the new format.
    So this broke CI when container updates are applied.

    Closes-Bug: #1772122
    Change-Id: I5256a1bee84f32629990c48c5e6e987384bd498f

Changed in tripleo:
status: In Progress → Fix Released

This issue was fixed in the openstack/tripleo-quickstart-extras 2.1.1 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers