ovb reproducer fails with "AnsibleUndefinedVariable: 'dict object' has no attribute 'ansible_host'"

Bug #1771563 reported by Matt Young on 2018-05-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
High
Unassigned

Bug Description

OVB CI reproducer is failing with:

```
TASK [ovb-manage-stack : Dump hosts to file]
fatal: [localhost]: FAILED! => {"changed": false, "failed": true, "msg": "AnsibleUndefinedVariable: 'dict object' has no attribute 'ansible_host'"}
 to retry, use: --limit @/home/matyoung/sprint13/1770972/wd-obv/tripleo-quickstart-extras/playbooks/ovb-create-stack.retry
```

when run thus:

./reproducer-quickstart.sh -w wd-ovb -v true -r true |& tee repro-ovb-take2.log

Full output: http://paste.openstack.org/show/721089

---

investigating root cause and/or ensuring this isn't operator error.

setting importance to "high" as this impacts ability to reproduce CI failures.

Ronelle Landy (rlandy) wrote :

Firstly, the error shows logged shows up in https://github.com/openstack/tripleo-quickstart-extras/blob/master/roles/ovb-manage-stack/tasks/ovb-create-stack.yml#L191 which only executes when ovb_dump_hosts|default('false')|bool.

So, in most cases, this step will never kick in an ovb reproducer.

When we force it execute,

TASK [ovb-manage-stack : Dump hosts to file] ***************************************************************************************************************************
changed: [localhost]

it worked for me.

wes hayutin (weshayutin) wrote :

<rlandy> myoung|ruck: hi - did you see my comment re: ovb reproducer?
<rlandy> wfm
<myoung|ruck> rlandy: auye, havne't tried again today, maybe I was hitting rdocloud at a bad time lol

Changed in tripleo:
status: Triaged → Incomplete
Changed in tripleo:
milestone: rocky-2 → rocky-3
Changed in tripleo:
milestone: rocky-3 → rocky-rc1
Changed in tripleo:
milestone: rocky-rc1 → stein-1
Changed in tripleo:
milestone: stein-1 → stein-2
Changed in tripleo:
milestone: stein-2 → stein-3
Changed in tripleo:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers