libvirt reproducer script fails on yum var $contentdir

Bug #1771498 reported by wes hayutin on 2018-05-16
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
tripleo
High
Unassigned

Bug Description

TASK [nodepool-setup : Install repos (will be removed by toci_gatetest)] ********************************************************************************************************************************************
changed: [subnode-0] => (item=centos-release-openstack-ocata)
failed: [subnode-0] (item=epel-release) => {"changed": false, "failed": true, "item": "epel-release", "msg": "Failure talking to yum: failure: repodata/repomd.xml from centos-qemu-ev: [Errno 256] No more mirrors to try.\nhttp://mirror.centos.org/$contentdir/7/virt/x86_64/kvm-common/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found"}
changed: [subnode-1] => (item=centos-release-openstack-ocata)
failed: [subnode-1] (item=epel-release) => {"changed": false, "failed": true, "item": "epel-release", "msg": "Failure talking to yum: failure: repodata/repomd.xml from centos-qemu-ev: [Errno 256] No more mirrors to try.\nhttp://mirror.centos.org/$contentdir/7/virt/x86_64/kvm-common/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found"}
 to retry, use: --limit @/var/tmp/docker/tripleo-quickstart-extras/playbooks/nodepool-setup.retry

Luckily Mr Steve Baker has a patch :)
https://review.openstack.org/#/c/568701/

This speaks to the need to get this script into CI, easier said then done.

Sorin Sbarnea (ssbarnea) wrote :

I got into this one hour ago. I hope this patch will go in quickly.

wes hayutin (weshayutin) wrote :

Sorin you can apply the patch to your box locally fairly easily.

on the dev box..

checkout the patch..
git fetch https://git.openstack.org/openstack/tripleo-quickstart-extras refs/changes/01/568701/8 && git checkout FETCH_HEAD

In the script.. remark out
https://github.com/openstack/tripleo-quickstart-extras/blob/master/roles/create-reproducer-script/templates/reproducer-quickstart.sh.j2#L192-L196

In your local working dir / -w $WORKSPACE e.g. ~/.quickstart or your setting
source venv_ansible/bin/activate
python setup.py install

Then re-execute

wes hayutin (weshayutin) wrote :

Clearly related to, but separate from https://bugs.launchpad.net/tripleo/+bug/1771090

Changed in tripleo:
milestone: rocky-2 → rocky-3
Changed in tripleo:
milestone: rocky-3 → rocky-rc1
Changed in tripleo:
milestone: rocky-rc1 → stein-1
Changed in tripleo:
milestone: stein-1 → stein-2
Changed in tripleo:
milestone: stein-2 → stein-3
Changed in tripleo:
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.