haproxy shows 'NO SERV' despite opendaylight up and operational

Bug #1768037 reported by Tim Rozet on 2018-04-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
High
Tim Rozet

Bug Description

This is a regression introduced by:
https://review.openstack.org/#/c/562036/

Due to removing any listening options, ODL now takes the default options which includes an http check. The http check fails because ODL does not respond a GET with no path specified. We can however use a httpchk to a URL (same one we use for tripleo-common healthcheck).

Reviewed: https://review.openstack.org/565229
Committed: https://git.openstack.org/cgit/openstack/puppet-tripleo/commit/?id=c53ea2512f963b1fa461fdedb853f9303dd042b1
Submitter: Zuul
Branch: master

commit c53ea2512f963b1fa461fdedb853f9303dd042b1
Author: Tim Rozet <email address hidden>
Date: Mon Apr 30 10:28:17 2018 -0400

    Fixes HA Proxy backend check for ODL

    This patch removed listen_options for ODL:
    https://review.openstack.org/#/c/562036/

    Which introduced a regression where default options were then applied
    for ODL, including httpchk. This does not work with ODL because ODL
    will not respond to an HTTP GET without specific paths used. This patch
    adds the correct path that may be used to issue HTTP backend check.

    Closes-Bug: 1768037

    Change-Id: I60bdfc436044851ac02449c262d382b07b888f79
    Signed-off-by: Tim Rozet <email address hidden>

Changed in tripleo:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/565539
Committed: https://git.openstack.org/cgit/openstack/puppet-tripleo/commit/?id=dc77dc23df47d5078602fd28c3dd94ff36368967
Submitter: Zuul
Branch: stable/queens

commit dc77dc23df47d5078602fd28c3dd94ff36368967
Author: Tim Rozet <email address hidden>
Date: Mon Apr 30 10:28:17 2018 -0400

    Fixes HA Proxy backend check for ODL

    This patch removed listen_options for ODL:
    https://review.openstack.org/#/c/562036/

    Which introduced a regression where default options were then applied
    for ODL, including httpchk. This does not work with ODL because ODL
    will not respond to an HTTP GET without specific paths used. This patch
    adds the correct path that may be used to issue HTTP backend check.

    Closes-Bug: 1768037

    Change-Id: I60bdfc436044851ac02449c262d382b07b888f79
    Signed-off-by: Tim Rozet <email address hidden>
    (cherry picked from commit c53ea2512f963b1fa461fdedb853f9303dd042b1)

tags: added: in-stable-queens

This issue was fixed in the openstack/puppet-tripleo 8.3.3 release.

This issue was fixed in the openstack/puppet-tripleo 9.1.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers