Error during test discovery : 'must specify exactly one of host or intercept'

Bug #1767049 reported by Quique Llorente on 2018-04-26
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
tripleo
High
Sagi (Sergey) Shnaidman

Bug Description

Running job periodic-tripleo-ci-centos-7-multinode-1ctlr-featureset017-master

https://logs.rdoproject.org/openstack-periodic/periodic-tripleo-ci-centos-7-multinode-1ctlr-featureset017-master/063b8fd/undercloud/home/jenkins/tempest_output.log.txt.gz
2018-04-26 00:48:12 | =========================
2018-04-26 00:48:12 | --- import errors ---
2018-04-26 00:48:12 | Failed to call load_tests:
2018-04-26 00:48:12 | Traceback (most recent call last):
2018-04-26 00:48:12 | File "/usr/lib/python2.7/site-packages/unittest2/loader.py", line 136, in loadTestsFromModule
2018-04-26 00:48:12 | return load_tests(self, tests, pattern)
2018-04-26 00:48:12 | File "/usr/lib/python2.7/site-packages/heat_tempest_plugin/tests/api/test_heat_api.py", line 96, in load_tests
2018-04-26 00:48:12 | test_loader_name=__name__)
2018-04-26 00:48:12 | File "/usr/lib/python2.7/site-packages/gabbi/driver.py", line 76, in build_tests
2018-04-26 00:48:12 | raise AssertionError('must specify exactly one of host or intercept')
2018-04-26 00:48:12 | AssertionError: must specify exactly one of host or intercept
2018-04-26 00:48:12 |

Tags: ci Edit Tag help
summary: - Error generating tempest.conf 'network_feature_enabled':
- NoSectionError: No section: 'network_feature_enabled'
+ Error during test discovery : 'must specify exactly one of host or
+ intercept'
yatin (yatinkarel) wrote :

Issue is caused by:- https://review.openstack.org/#/c/544025/. This requires gabbi >= 1.42.1 but we have 1.33.

Currently pinned heat-tempest-plugin to Good Hash in master and queens:-
master:- https://review.rdoproject.org/r/#/c/13543/
queens:- https://review.rdoproject.org/r/#/c/13545/

Pin from master will be removed once we are ready with gabbi 1.42.1 in deps repo.
Bugzilla for gabbi update:- https://bugzilla.redhat.com/show_bug.cgi?id=1434385

Changed in tripleo:
status: New → Confirmed
tags: added: alert
Changed in tripleo:
status: Confirmed → Triaged
Changed in tripleo:
importance: Critical → High
tags: removed: alert promotion-blocker
Changed in tripleo:
status: Triaged → In Progress
Changed in tripleo:
assignee: Quique Llorente (quiquell) → Sagi (Sergey) Shnaidman (sshnaidm)
Changed in tripleo:
milestone: rocky-2 → rocky-3
Changed in tripleo:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.