telemetry composable role doesn't work with swift

Bug #1766507 reported by Mehdi Abaakouk on 2018-04-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
High
Mehdi Abaakouk

Bug Description

Hi,

Telemetry composable role doesn't work if not installed on Controller nodes, because Gnocchi can't access to Swift:

/var/log/containers/gnocchi/gnocchi-metricd.log

2018-04-22 11:05:46,519 [25] ERROR gnocchi.storage: Error processing new measures
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/gnocchi/storage/__init__.py", line 505, in process_new_measures
    self._compute_and_store_timeseries(metric, measures)
  File "/usr/lib/python2.7/site-packages/gnocchi/storage/__init__.py", line 532, in _compute_and_store_timeseries
    metric, block_size=block_size, back_window=back_window)
  File "/usr/lib/python2.7/site-packages/gnocchi/storage/__init__.py", line 154, in _get_unaggregated_timeserie_and_unserialize
    metric)
  File "/usr/lib/python2.7/site-packages/gnocchi/storage/swift.py", line 193, in _get_unaggregated_timeserie
    self._build_unaggregated_timeserie_path(version))
  File "/usr/lib/python2.7/site-packages/swiftclient/client.py", line 1799, in get_object
    headers=headers)
  File "/usr/lib/python2.7/site-packages/swiftclient/client.py", line 1691, in _retry
    service_token=self.service_token, **kwargs)
  File "/usr/lib/python2.7/site-packages/swiftclient/client.py", line 1167, in get_object
    conn.request(method, path, '', headers)
  File "/usr/lib/python2.7/site-packages/swiftclient/client.py", line 439, in request
    files=files, **self.requests_args)
  File "/usr/lib/python2.7/site-packages/swiftclient/client.py", line 422, in _request
    return self.request_session.request(*arg, **kwarg)
  File "/usr/lib/python2.7/site-packages/requests/sessions.py", line 518, in request
    resp = self.send(prep, **send_kwargs)
  File "/usr/lib/python2.7/site-packages/requests/sessions.py", line 639, in send
    r = adapter.send(request, **kwargs)
  File "/usr/lib/python2.7/site-packages/requests/adapters.py", line 502, in send
    raise ConnectionError(e, request=request)
ConnectionError: HTTPConnectionPool(host='172.17.3.11', port=8080): Max retries exceeded with url: /v1/AUTH_2e5439d447fb4f008396fd56d7d5bd7a/gnocchi.2845f016-a151-46b2-a552-51b37ad6a60c/none_v3 (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x7f2c9e550e50>: Failed to establish a new connection: [Errno 113] No route to host',))

Cheers,

Mehdi Abaakouk (sileht) on 2018-04-24
Changed in tripleo:
assignee: nobody → Mehdi Abaakouk (sileht)
Mehdi Abaakouk (sileht) wrote :
Changed in tripleo:
status: New → In Progress
Mehdi Abaakouk (sileht) on 2018-04-24
description: updated
Changed in tripleo:
importance: Undecided → High
milestone: none → rocky-2

Reviewed: https://review.openstack.org/563715
Committed: https://git.openstack.org/cgit/openstack/tripleo-heat-templates/commit/?id=af30f2320787d344d524c8528daca320ef66def2
Submitter: Zuul
Branch: stable/queens

commit af30f2320787d344d524c8528daca320ef66def2
Author: Mehdi Abaakouk <email address hidden>
Date: Mon Apr 23 09:34:00 2018 +0200

    Telemetry services need to access to Storage

    Gnocchi stores data in Swift or Ceph. So when composable roles are used
    it needs to access to the Storage network to connect to them.

    Closes-bug: #1766507

    Change-Id: I11f4ec4a91a9240bde6d504a84351185ed5a6997
    (cherry picked from commit 39f5b64394310e19720021785a26e302b926eded)

tags: added: in-stable-queens
tags: added: in-stable-pike

Reviewed: https://review.openstack.org/563716
Committed: https://git.openstack.org/cgit/openstack/tripleo-heat-templates/commit/?id=902ccd61ffe785bfcba8d103470078ae0ae7e857
Submitter: Zuul
Branch: stable/pike

commit 902ccd61ffe785bfcba8d103470078ae0ae7e857
Author: Mehdi Abaakouk <email address hidden>
Date: Mon Apr 23 09:34:00 2018 +0200

    Telemetry services need to access to Storage

    Gnocchi stores data in Swift or Ceph. So when composable roles are used
    it needs to access to the Storage network to connect to them.

    Closes-bug: #1766507
    Change-Id: I11f4ec4a91a9240bde6d504a84351185ed5a6997
    (cherry picked from commit 39f5b64394310e19720021785a26e302b926eded)

This issue was fixed in the openstack/tripleo-heat-templates 7.0.13 release.

This issue was fixed in the openstack/tripleo-heat-templates 8.0.3 release.

Changed in tripleo:
milestone: rocky-2 → rocky-3
Changed in tripleo:
milestone: rocky-3 → rocky-rc1
Changed in tripleo:
milestone: rocky-rc1 → stein-1
Changed in tripleo:
milestone: stein-1 → stein-2
Changed in tripleo:
milestone: stein-2 → stein-3
Changed in tripleo:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers