Nova::Cell_v2::Simple_setup/Nova_cell_v2[cell0] fails on master promote

Bug #1744780 reported by John Trowbridge on 2018-01-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Medium
Dan Smith
tripleo
Critical
Unassigned

Bug Description

FS20 is failing in the promote pipeline for master during deploy. It looks like we have a regression in either nova or puppet-nova.

The error in the deploy logs is:

"Error: /Stage[main]/Nova::Cell_v2::Simple_setup/Nova_cell_v2[cell0]: Could not evaluate: Execution of '/usr/bin/nova-manage cell_v2 update_cell --cell_uuid 00000000-0000-0000-0000-000000000000 --transport-url none:/// --database_connection mysql+pymysql://nova:QWDqCAV6AmavmFxPPpxCJecd6@192.168.24.8/nova_cell0?read_default_group=tripleo&read_default_file=/etc/my.cnf.d/tripleo.cnf' returned 3: The specified transport_url and/or database_connection combination already exists for another cell with uuid 00000000-0000-0000-0000-000000000000.",

Full logs for the job at:

https://logs.rdoproject.org/openstack-periodic/periodic-tripleo-ci-centos-7-ovb-1ctlr_1comp-featureset020-master/12230cb

John Trowbridge (trown) wrote :

Actually https://review.openstack.org/518556 is 100% the root cause. There was no exit code 3 from nova-manage before that commit.

Still need to determine where/how/why we are providing a transport_url or/and database_connection that are the same as another cell.

Changed in tripleo:
importance: High → Critical
Oliver Walsh (owalsh) wrote :

That fix needs to omit the cell being updated from the cells that are inspected for conflicts.

melanie witt (melwitt) on 2018-01-22
Changed in nova:
importance: Undecided → Medium
status: New → Triaged
tags: added: cells

Fix proposed to branch: master
Review: https://review.openstack.org/536546

Changed in nova:
assignee: nobody → Dan Smith (danms)
status: Triaged → In Progress

Reviewed: https://review.openstack.org/536546
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=0467b537bfcf0cb973eb74b49ff7207dafbdbdbc
Submitter: Zuul
Branch: master

commit 0467b537bfcf0cb973eb74b49ff7207dafbdbdbc
Author: Dan Smith <email address hidden>
Date: Mon Jan 22 11:57:53 2018 -0800

    Fix update_cell to ignore existing identical cells

    The recent cell duplication filter makes it impossible to do update_cell
    on an existing cell with identical details. If we're updating a cell by
    uuid and specify the exact same parameters, we shouldn't signal failure.

    Change-Id: I2faaec94444bc7d29fda1facd22e0da3bc6f01f9
    Closes-Bug: #1744780

Changed in nova:
status: In Progress → Fix Released
John Trowbridge (trown) wrote :
Changed in tripleo:
status: Triaged → Fix Released

This issue was fixed in the openstack/nova 17.0.0.0b3 development milestone.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers