Packaging: Gnocchi renaming broke systemd services

Bug #1739686 reported by Emilien Macchi on 2017-12-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
High
Pradeep Kilambi

Bug Description

Gnocchi packages & services were renamed: https://review.rdoproject.org/r/#/c/10736
But now the services don't start anymore with the old name, even though Alias is used in the service unit file.

It's breaking scenario001 in both TripleO & Puppet promotions CI.

Emilien Macchi (emilienm) wrote :

To make it work, we had to run:

systemctl disable gnocchi-metricd.service
systemctl disable gnocchi-statsd.service

systemctl enable gnocchi-metricd.service
systemctl enable gnocchi-statsd.service

So it's probably a packaging bug...

Emilien Macchi (emilienm) wrote :

So the problem is that Puppet tries to enable the service with the old name but systemd expects the new name so it can creates the symlinks.
Which means "Alias" in the .service file only works after having enabling the service with the new name.

We're disabling Gnocchi everywhere until we promote.

Emilien Macchi (emilienm) wrote :

In fact, we decided to revert because it affects all RDO users, not only TripleO and Puppet.
Gnocchi devs will have to figure out a backward compatible way that actually works.

We're reverting now so we can continue to promote Puppet & TripleO CI.
We'll let Gnocchi folks decide how to move forward. Multiple options:

- disable Gnocchi in TripleO & Puppet, rename gnocchi packages/services in puppet-gnocchi and promotion will pass.
- ship multiple .service files (but can cause issue, not tested).

In any case, we don't want to take decision for them, so we revert now, since it's blocking the production chain.

Emilien Macchi (emilienm) wrote :
Changed in tripleo:
status: Triaged → In Progress
assignee: Emilien Macchi (emilienm) → Pradeep Kilambi (pkilambi)
tags: removed: alert promotion-blocker
Changed in tripleo:
importance: Critical → High
tags: added: tech-debt
removed: ci
Mehdi Abaakouk (sileht) wrote :

I proposed a new version without this issue: https://review.rdoproject.org/r/#/c/11110/

Changed in tripleo:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers