Telemetry tempest tests fail due to Max retries exceeded with url: /nodata-gnocchi-threshold-resource

Bug #1736475 reported by Sagi (Sergey) Shnaidman on 2017-12-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Critical
wes hayutin

Bug Description

Telemetry tempest tests fail in pike promotion job periodic-tripleo-ci-centos-7-multinode-1ctlr-featureset017-pike

https://logs.rdoproject.org/openstack-periodic/periodic-tripleo-ci-centos-7-multinode-1ctlr-featureset017-pike/4c26743/

Tempest failures:

https://logs.rdoproject.org/openstack-periodic/periodic-tripleo-ci-centos-7-multinode-1ctlr-featureset017-pike/4c26743/undercloud/home/jenkins/tempest_output.log.txt.gz

ceilometer.tests.tempest.scenario.test_telemetry_integration.TestTelemetryIntegration.test_autoscaling (subunit.RemotedTestCase)
tearDownClass (ceilometer.tests.tempest.scenario.test_telemetry_integration.TestTelemetryIntegration) (subunit.RemotedTestCase

wes hayutin (weshayutin) on 2017-12-06
Changed in tripleo:
milestone: none → queens-3
wes hayutin (weshayutin) wrote :

https://logs.rdoproject.org/openstack-periodic/periodic-tripleo-ci-centos-7-multinode-1ctlr-featureset017-pike/d4cead3/subnode-2/var/log/containers/aodh/aodh-notifier.log.txt.gz#_2017-12-06_17_38_24_668

2017-12-06 17:38:24.479 24 INFO aodh.notifier.rest [-] Notifying alarm gabbi-gnocchi-threshold-resource-alarm 4a526356-6b80-4484-a633-76f383e6485f with severity low from ok to insufficient data with action SplitResult(scheme=u'http', netloc=u'site:8000', path=u'/nodata-gnocchi-threshold-resource', query='', fragment='') because No datapoint for granularity 60. request-id: req-a21aa1d5-73a9-4b47-967e-c1631f2b3a1b
2017-12-06 17:38:24.668 24 ERROR aodh.notifier [-] Unable to notify alarm 4a526356-6b80-4484-a633-76f383e6485f: ConnectionError: HTTPConnectionPool(host='site', port=8000): Max retries exceeded with url: /nodata-gnocchi-threshold-resource (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x7f75f001e1d0>: Failed to establish a new connection: [Errno -2] Name or service not known',))
2017-12-06 17:38:24.668 24 ERROR aodh.notifier Traceback (most recent call last):
2017-12-06 17:38:24.668 24 ERROR aodh.notifier File "/usr/lib/python2.7/site-packages/aodh/notifier/__init__.py", line 139, in _handle_action
2017-12-06 17:38:24.668 24 ERROR aodh.notifier previous, current, reason, reason_data)
2017-12-06 17:38:24.668 24 ERROR aodh.notifier File "/usr/lib/python2.7/site-packages/aodh/notifier/rest.py", line 105, in notify
2017-12-06 17:38:24.668 24 ERROR aodh.notifier resp = session.post(action.geturl(), **kwargs)
2017-12-06 17:38:24.668 24 ERROR aodh.notifier File "/usr/lib/python2.7/site-packages/requests/sessions.py", line 565, in post
2017-12-06 17:38:24.668 24 ERROR aodh.notifier return self.request('POST', url, data=data, json=json, **kwargs)
2017-12-06 17:38:24.668 24 ERROR aodh.notifier File "/usr/lib/python2.7/site-packages/requests/sessions.py", line 518, in request
2017-12-06 17:38:24.668 24 ERROR aodh.notifier resp = self.send(prep, **send_kwargs)
2017-12-06 17:38:24.668 24 ERROR aodh.notifier File "/usr/lib/python2.7/site-packages/requests/sessions.py", line 639, in send
2017-12-06 17:38:24.668 24 ERROR aodh.notifier r = adapter.send(request, **kwargs)
2017-12-06 17:38:24.668 24 ERROR aodh.notifier File "/usr/lib/python2.7/site-packages/requests/adapters.py", line 502, in send
2017-12-06 17:38:24.668 24 ERROR aodh.notifier raise ConnectionError(e, request=request)
2017-12-06 17:38:24.668 24 ERROR aodh.notifier ConnectionError: HTTPConnectionPool(host='site', port=8000): Max retries exceeded with url: /nodata-gnocchi-threshold-resource (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x7f75f001e1d0>: Failed to establish a new connection: [Errno -2] Name or service not known',))
2017-12-06 17:38:24.668 24 ERROR aodh.notifier

summary: - Telemetry tempest tests fail in pike promotion job periodic-tripleo-ci-
- centos-7-multinode-1ctlr-featureset017-pike
+ Telemetry tempest tests fail due to Max retries exceeded with url:
+ /nodata-gnocchi-threshold-resource
wes hayutin (weshayutin) on 2017-12-07
tags: added: alert
Changed in tripleo:
assignee: nobody → Emilien Macchi (emilienm)

Fix proposed to branch: master
Review: https://review.openstack.org/526459

Changed in tripleo:
status: Triaged → In Progress
Changed in tripleo:
assignee: Emilien Macchi (emilienm) → wes hayutin (weshayutin)

Reviewed: https://review.openstack.org/526459
Committed: https://git.openstack.org/cgit/openstack/tripleo-quickstart/commit/?id=3f6c12e87e7b1860759615a79b87fac090d7c1b8
Submitter: Zuul
Branch: master

commit 3f6c12e87e7b1860759615a79b87fac090d7c1b8
Author: Emilien Macchi <email address hidden>
Date: Thu Dec 7 08:50:38 2017 -0800

    scenario002-container: ignore telemetry & barbican tests

    We made Telemetry tests working in Queens cycle, not before, so we don't
    want to execute the tests in stable branches.

    Co-Authored-By: Wesley Hayutin <email address hidden>
    Closes-Bug: #1736475
    Change-Id: I13e05e9d9462554465aeced856860a45e1740f27

Changed in tripleo:
status: In Progress → Fix Released

This issue was fixed in the openstack/tripleo-quickstart 2.1.1 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers