CI: new centos7 image contains a regression that prevents multinode networking setup to work

Bug #1725451 reported by Emilien Macchi on 2017-10-20
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
tripleo
Critical
Unassigned

Bug Description

Affecting at least master and Pike (maybe more) but the undercloud fails to deploy because multinode setup hasn't finished correctly, the subnode-2 can't be pinged:

http://logs.openstack.org/75/508975/13/check/legacy-tripleo-ci-centos-7-nonha-multinode-oooq/9045427/job-output.txt.gz#_2017-10-20_18_29_35_247147

I did some quick research and I think this is in the new centos7 image, where we have updates on some core packages:
https://www.diffchecker.com/huccl3ol

See iptables, it was upgraded and could be the reason.
Release note of latest tag:
https://git.centos.org/blob/rpms!iptables.git/4d0bb22ecdc68576e7a4a7afd966207c50b664d2/SPECS!iptables.spec#L278

It's maybe not iptables, but this bug serves as placeholder.

Tags: ci Edit Tag help
Changed in tripleo:
assignee: nobody → Emilien Macchi (emilienm)
David Moreau Simard (dmsimard) wrote :

It looks like there is a known issue in the last release of iptables: https://bugzilla.redhat.com/show_bug.cgi?id=1504647

David Moreau Simard (dmsimard) wrote :

Also note that a restart of iptables clears the rules, they are not properly persisted.

wes hayutin (weshayutin) wrote :

Weird, things are working again w/o either:
https://review.openstack.org/513848 or
https://review.openstack.org/#/c/513943/

Don't see any discussion on #tripleo or #openstack-infra
The passing jobs are still using the new iptables
iptables-services.x86_64 1.4.21-18.2.el7_4 @updates

odd, anyone have any hints?

Change abandoned by Emilien Macchi (<email address hidden>) on branch: master
Review: https://review.openstack.org/513848

tags: removed: alert
Changed in tripleo:
assignee: Emilien Macchi (emilienm) → nobody
Changed in tripleo:
milestone: queens-2 → queens-3
Changed in tripleo:
milestone: queens-3 → queens-rc1
Alex Schultz (alex-schultz) wrote :

I think https://review.openstack.org/#/c/513943/ resolved this issue. We are not currently hitting this so closing it.

Changed in tripleo:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.