Some packages are not installed in gate job

Bug #1722872 reported by Honza Pokorny on 2017-10-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
High
Unassigned

Bug Description

http://logs.openstack.org/09/505609/5/check/gate-tripleo-ui-nodejs6-npm-run-test/4b53880/console.html#_2017-10-11_15_03_16_892566

This is perhaps caused by ubuntu repos not being signed (a few lines above):

2017-10-11 15:03:11.567617 | + sudo apt-get -qq update
2017-10-11 15:03:12.841258 | W: The repository 'http://mirror.bhs1.ovh.openstack.org/ubuntu xenial Release' is not signed.
2017-10-11 15:03:12.841356 | W: The repository 'http://mirror.bhs1.ovh.openstack.org/ubuntu xenial-updates Release' is not signed.
2017-10-11 15:03:12.841395 | W: The repository 'http://mirror.bhs1.ovh.openstack.org/ubuntu xenial-backports Release' is not signed.
2017-10-11 15:03:12.841430 | W: The repository 'http://mirror.bhs1.ovh.openstack.org/ubuntu xenial-security Release' is not signed.
2017-10-11 15:03:12.843261 | ++ /usr/bindep-env/bin/bindep -b -f /usr/local/jenkins/common_data/bindep-fallback.txt test
2017-10-11 15:03:14.077364 | + sudo PATH=/usr/sbin:/sbin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games DEBIAN_FRONTEND=noninteractive apt-get -q --option Dpkg::Options::=--force-confold --assume-yes install fonts-nanum fonts-takao gawk gettext graphviz language-pack-en libcurl4-gnutls-dev liberasurecode-dev libevent-dev libffi-dev libjerasure-dev libjpeg-dev libldap2-dev libmysqlclient-dev libpcap-dev libpq-dev librrd-dev libsasl2-dev libsqlite3-dev libvirt-dev libxml2-dev libxml2-utils libxslt1-dev memcached mongodb mysql-client mysql-server pkg-config postgresql postgresql-client pypy pypy-dev python-libvirt python-lxml python-zmq python3-all python3-all-dev redis-server ruby sqlite3 swig unzip uuid-dev xsltproc zip zlib1g-dev zookeeperd
2017-10-11 15:03:14.119243 | Reading package lists...
2017-10-11 15:03:14.260351 | Building dependency tree...
2017-10-11 15:03:14.260591 | Reading state information...
2017-10-11 15:03:14.318253 | Some packages could not be installed. This may mean that you have
2017-10-11 15:03:14.318386 | requested an impossible situation or if you are using the unstable
2017-10-11 15:03:14.318442 | distribution that some required packages have not yet been created
2017-10-11 15:03:14.318473 | or been moved out of Incoming.
2017-10-11 15:03:14.318586 | The following information may help to resolve the situation:
2017-10-11 15:03:14.318607 |
2017-10-11 15:03:14.318647 | The following packages have unmet dependencies:
2017-10-11 15:03:14.373326 | libcurl4-gnutls-dev : Depends: libcurl3-gnutls (= 7.47.0-1ubuntu2.2) but 7.47.0-1ubuntu2.3 is to be installed
2017-10-11 15:03:14.382860 | E: Unable to correct problems, you have held broken packages.

This is blocking tripleo-ui patches.

Tags: ci Edit Tag help
Alex Schultz (alex-schultz) wrote :

I wonder if this is related to the mentioned version conflicts between UCA/mainline in http://lists.openstack.org/pipermail/openstack-dev/2017-October/123464.html

Changed in tripleo:
milestone: none → queens-1
Changed in tripleo:
milestone: queens-1 → queens-2
Changed in tripleo:
milestone: queens-2 → queens-3
Changed in tripleo:
milestone: queens-3 → queens-rc1
Changed in tripleo:
milestone: queens-rc1 → rocky-1
Changed in tripleo:
milestone: rocky-1 → rocky-2
Changed in tripleo:
milestone: rocky-2 → rocky-3
Changed in tripleo:
milestone: rocky-3 → rocky-rc1
Changed in tripleo:
milestone: rocky-rc1 → stein-1
Changed in tripleo:
milestone: stein-1 → stein-2
Changed in tripleo:
milestone: stein-2 → stein-3
Changed in tripleo:
milestone: stein-3 → stein-rc1
Changed in tripleo:
milestone: stein-rc1 → train-1
Changed in tripleo:
milestone: train-1 → train-2
Changed in tripleo:
milestone: train-2 → train-3
Changed in tripleo:
milestone: train-3 → ussuri-1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers