CI: Most/all legacy-tripleo jobs failing on gate

Bug #1720220 reported by Alex Schultz on 2017-09-28
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
tripleo
Critical
Unassigned
summary: - CI: legacy-tripleo jobs faiing on gate_hook: not found
+ CI: legacy-tripleo jobs failing on gate_hook: not found

Multi-node jobs were not migrated with multinode nodesets, review here: https://review.openstack.org/#/c/508292/

David Moreau Simard (dmsimard) wrote :

OVB jobs were not migrated with the tripleo-centos-7 nodesets, review here: https://review.openstack.org/508301

wes hayutin (weshayutin) wrote :

Both reviews have merged.

David Moreau Simard (dmsimard) wrote :

We're past the sudoers error as well as the nodeset errors now.
New error is:

2017-09-29 14:01:35.457 | ++ /home/zuul/workspace/devstack-gate/functions.sh:setup_workspace:L414: basename openstack/ceilometer
2017-09-29 14:01:35.459 | + /home/zuul/workspace/devstack-gate/functions.sh:setup_workspace:L414: rsync -a '/home/zuul/src/*/openstack/ceilometer/' ceilometer
2017-09-29 14:01:35.461 | rsync: change_dir "/home/zuul/src/*/openstack/ceilometer" failed: No such file or directory (2)

http://logs.openstack.org/89/507889/2/check/legacy-tripleo-ci-centos-7-scenario003-multinode-oooq-puppet/603ef1f/logs/devstack-gate-setup-workspace-new.txt

summary: - CI: legacy-tripleo jobs failing on gate_hook: not found
+ CI: Most/all legacy-tripleo jobs failing on gate
David Moreau Simard (dmsimard) wrote :

It looks like the next issue is the following:

/opt/stack/new/tripleo-ci/toci_gate_test.sh: line 154: NODEPOOL_PROVIDER: unbound variable
http://logs.openstack.org/89/507889/2/check/legacy-tripleo-ci-centos-7-scenario004-multinode-oooq-puppet/3f7277c/ara/result/c4c9c0cc-fb0b-45e4-b185-0126dd8a6360/

wes hayutin (weshayutin) wrote :

I opened this [1] bug over the weekend, is it a dupe of this one 1720220?

[1] https://bugs.launchpad.net/tripleo/+bug/1720556

tags: added: promotion-blocker
David Moreau Simard (dmsimard) wrote :

Fix for nodepool provider: https://review.openstack.org/#/c/508714/

David Moreau Simard (dmsimard) wrote :

I suspect we might need patches like these [1] for tripleo, let's wait and see what 508714 gives.

[1]: https://review.openstack.org/#/q/topic:fix-multinode

just FYI, I'm working on this too in https://review.openstack.org/#/c/508660/

See also bug for all OVB jobs: https://bugs.launchpad.net/tripleo/+bug/1720721
"CI: OVB jobs fail because can't install XStatic from PyPI mirror on rh1 cloud"

Currently the main problem is hardlinks failure, the patch that should solve it[1] doesn't work for all jobs consistently.
My patch also fixes from "jenkins" user to "zuul", patch for cirros image, moving "sub_nodes" to "sub_nodes_private" other things: https://review.openstack.org/#/c/508660/
It depends also on few patches in quickstart and extras.

[1] https://review.openstack.org/#/c/508772/

Alex Schultz (alex-schultz) wrote :

Upstream switched back to zuul v2. Removing alert tag, adding zuulv3.

tags: added: zuulv3
removed: alert
wes hayutin (weshayutin) wrote :

zuul v2 jobs seem stable, can we close this?

Alex Schultz (alex-schultz) wrote :

Closing this for now as we're on v2 and v3 is getting worked on

Changed in tripleo:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers