UI is not browsable by default in OVB

Bug #1719490 reported by Steve Baker on 2017-09-26
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
tripleo
Medium
Steve Baker

Bug Description

The TripleO UI cannot be accessed in a new quickstart OVB deploy without extra port tunnelling steps. This raises the barrier to non-UI folk trying or developing the UI.

There are a few changes required for this, which will probably all be done in tripleo-quickstart
- apache should bind to the IP on the private network, not the provision network
- tripleo_ui_config.js should be generated with the IP of the undercloud floating IP
- the undercloud OVB security group should allow incoming TCP port 3000
- the end of the quickstart run should output the url to launch the UI

Changed in tripleo:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Steve Baker (steve-stevebaker)
milestone: none → queens-1
tags: added: quickstart ui

Fix proposed to branch: master
Review: https://review.openstack.org/507969

Changed in tripleo:
status: Triaged → In Progress
Changed in tripleo:
milestone: queens-1 → queens-2
Changed in tripleo:
assignee: Steve Baker (steve-stevebaker) → Sagi (Sergey) Shnaidman (sshnaidm)
Changed in tripleo:
assignee: Sagi (Sergey) Shnaidman (sshnaidm) → Steve Baker (steve-stevebaker)
Changed in tripleo:
milestone: queens-2 → queens-3
Changed in tripleo:
assignee: Steve Baker (steve-stevebaker) → Sagi (Sergey) Shnaidman (sshnaidm)
Changed in tripleo:
assignee: Sagi (Sergey) Shnaidman (sshnaidm) → Steve Baker (steve-stevebaker)
Changed in tripleo:
milestone: queens-3 → queens-rc1
Dan Trainor (dtrainor) wrote :

Just a note that as described, these type of changes will only affect non-SSL Undercloud deployments. In order to make this work with an SSL Undercloud, in addition to the above, we would need:

- haproxy should bind to the IP on the private network, not the provision network (443/tcp)
- tripleo_ui_config.js should be generated with the IP of the undercloud floating IP (whilst appending :443/<servicename> to the URI
- the undercloud OVB security group should allow incoming TCP port 443

Changed in tripleo:
milestone: queens-rc1 → rocky-1
Changed in tripleo:
milestone: rocky-1 → rocky-2

Change abandoned by Sagi Shnaidman (<email address hidden>) on branch: master
Review: https://review.openstack.org/507969
Reason: According to TripleO policy of patch abandonment https://github.com/openstack/tripleo-specs/blob/master/specs/policy/patch-abandomment.rst, this patch is abandoned. If you would like to continue to work on it, please ask for restoration either on #tripleo in Freenode IRC, or openstack dev mailing list - <email address hidden> with [TripleO] in subject. Thanks.

Changed in tripleo:
milestone: rocky-2 → rocky-3
Changed in tripleo:
milestone: rocky-3 → rocky-rc1
Changed in tripleo:
milestone: rocky-rc1 → stein-1
Changed in tripleo:
milestone: stein-1 → stein-2
Changed in tripleo:
milestone: stein-2 → stein-3
Changed in tripleo:
status: In Progress → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers