/etc/machine-id doesn't exist causing logs not to be populated.

Bug #1719421 reported by wes hayutin on 2017-09-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Critical
John Trowbridge
John Trowbridge (trown) wrote :

Need to find some ocata gate logs and successful master/pike periodic jobs... it is not happening on master gate jobs:

http://logs.openstack.org/22/506922/9/check-tripleo/gate-tripleo-ci-centos-7-ovb-ha-oooq/a15082a/logs/overcloud-controller-0/var/log/messages.txt.gz

John Trowbridge (trown) wrote :

I think this bug is invalid. It is not that the job is not collecting logs properly. The logs just are not there.

ocata gate job:

http://logs.openstack.org/47/494947/6/check-tripleo/gate-tripleo-ci-centos-7-ovb-ha-oooq/2a4ad63/logs/overcloud-controller-0/var/log/messages.txt.gz

also the journal is also has no entries on one of the jobs above:

http://logs.openstack.org/periodic/periodic-tripleo-ci-centos-7-ovb-ha-ocata-oooq/3f84978/logs/overcloud-controller-0/var/log/journal.txt.gz

There seems to be a bug on ocata periodic, but I dont think it is quickstart related.

Alfredo Moralejo (amoralej) wrote :

I've reproduced that in a environment when i can access. The problem is that journald is failing to start because file /etc/machine-id doesn't exist. This file is created on boot by /usr/bin/systemd-machine-id-setup (in fact, running it manually, it started properly). I'm still trying to find out the root cause why this is happening using tripleo images (it works fine in undercloud)

wes hayutin (weshayutin) on 2017-09-26
summary: - tripleo-ci quickstart ovb jobs are not collecting files properly
+ /etc/machine-id doesn't exist causing logs not to be filled out.
tags: added: promotion-blocker
Changed in tripleo:
importance: High → Critical
tags: added: alert
summary: - /etc/machine-id doesn't exist causing logs not to be filled out.
+ /etc/machine-id doesn't exist causing logs not to be populated.

Reviewed: https://review.openstack.org/507495
Committed: https://git.openstack.org/cgit/openstack/tripleo-puppet-elements/commit/?id=1eeaf432b7be2571ac53330c45d96f68ffae5a5d
Submitter: Jenkins
Branch: stable/ocata

commit 1eeaf432b7be2571ac53330c45d96f68ffae5a5d
Author: Alex Schultz <email address hidden>
Date: Tue Aug 1 08:22:20 2017 -0600

    Set remove-machine-id to executable

    We had previously added an element to remove the machine id from the
    images however the script is not executable so it wasn't actually being
    run as part of the image building process. This change sets
    70-remove-machine-id to be executable so that /etc/machine-id will
    actually be removed from the images during the building process.
    Additionally this changes the element to clear the file rather than
    delete it as if the file is missing, things may not work as expected.

    element remove-machine-id has been added to tripleo-common in stable/ocata
    and we are experiencing strange issues related to missing /etc/machine-id

    Closes-Bug: #1719421

    Change-Id: Id3f8c510801f8fcc1fc03415b0ebd23a2ff9da4c
    (cherry picked from commit ab7ac88006c6c26bbebbe6862792f89d34a65236)

tags: added: in-stable-ocata
Changed in tripleo:
status: Triaged → Fix Released

This issue was fixed in the openstack/tripleo-puppet-elements 6.2.3 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers