manila: need to override default setting for 'host'

Bug #1712842 reported by Tom Barron on 2017-08-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
High
Tom Barron

Bug Description

<email address hidden> reports:

Description of problem:
When the Active share service stops and another, passive share service takes over as the active, when the share service that was stopped comes back, the shares that were on the other share service will become unavailable for Manila to control.

Version-Release number of selected component (if applicable):
openstack-manila-3.0.0-8.el7ost.noarch
openstack-manila-ui-2.5.1-9.el7ost.noarch
puppet-manila-9.5.0-1.el7ost.noarch
python-manilaclient-1.11.0-1.el7ost.noarch
python-manila-3.0.0-8.el7ost.noarch
openstack-manila-share-3.0.0-8.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Use Infrared to deploy an OSP-10z4 deployment with Manila and with at least 2 controller nodes and any number of compute nodes. I used a NetApp backend for the storage.
2. Disable the active Manila Share service. Observe that the service will start on another controller node.
3. Create a share on the new share service.
4. Re-enable the disabled share service and observe that the share that was created is no longer controllable by Manila.

Actual results:
Manila shares created on the other share service become uncontrollable when the first share service is reactivated.

Expected results:
Disruption of the share service shall not impact Manila shares.

Additional info:
I looked into how Cinder does Volume service HA and they use a hostgroup for all of the volume services so that the "hostname" of the volume service does not change when another volume service takes over the active role. Chances are something similar will need to happen to Manila as well.

Tom Barron (tpb) on 2017-08-24
Changed in tripleo:
assignee: nobody → Tom Barron (tpb)
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/497482

Changed in tripleo:
status: Confirmed → In Progress
Tom Barron (tpb) on 2017-08-24
tags: added: newton-backport-potential
Tom Barron (tpb) on 2017-08-24
tags: added: ocata-backport-potential
Changed in tripleo:
importance: Undecided → Medium
milestone: none → queens-1
milestone: queens-1 → pike-rc2

Reviewed: https://review.openstack.org/497482
Committed: https://git.openstack.org/cgit/openstack/tripleo-heat-templates/commit/?id=8fa6c6e58c7ac0d32bf2f0dfb586683cf006e3bf
Submitter: Jenkins
Branch: master

commit 8fa6c6e58c7ac0d32bf2f0dfb586683cf006e3bf
Author: Tom Barron <email address hidden>
Date: Thu Aug 24 12:27:20 2017 -0400

    manila: set "host" to "hostgroup"

    when running manila-share under control of pacemaker, as
    is done for cinder-volume service in the same circumstance.

    Change-Id: Ic97f01913bae2a388c962a38fa175eb1d763cdcb
    Depends-On: Ie31f2d5ccf458f5fcfe8bec5f2c37f45070cfde2
    Closes-Bug: #1712842

Changed in tripleo:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/498664
Committed: https://git.openstack.org/cgit/openstack/tripleo-heat-templates/commit/?id=1f3cb179b8e668f9a4e2c2307b60b4ceecd877f4
Submitter: Jenkins
Branch: stable/pike

commit 1f3cb179b8e668f9a4e2c2307b60b4ceecd877f4
Author: Tom Barron <email address hidden>
Date: Thu Aug 24 12:27:20 2017 -0400

    manila: set "host" to "hostgroup"

    when running manila-share under control of pacemaker, as
    is done for cinder-volume service in the same circumstance.

    Change-Id: Ic97f01913bae2a388c962a38fa175eb1d763cdcb
    Depends-On: Ie31f2d5ccf458f5fcfe8bec5f2c37f45070cfde2
    Closes-Bug: #1712842
    (cherry picked from commit 8fa6c6e58c7ac0d32bf2f0dfb586683cf006e3bf)

tags: added: in-stable-pike

This issue was fixed in the openstack/tripleo-heat-templates 7.0.0.0rc2 release candidate.

Tom Barron (tpb) wrote :

Setting this to High priority since we have customers on Newton who need this fix.

Changed in tripleo:
importance: Medium → High

Reviewed: https://review.openstack.org/499111
Committed: https://git.openstack.org/cgit/openstack/tripleo-heat-templates/commit/?id=87d4bdf6932f6e10867d6c3ae4717c25e9ad93a4
Submitter: Jenkins
Branch: stable/ocata

commit 87d4bdf6932f6e10867d6c3ae4717c25e9ad93a4
Author: Tom Barron <email address hidden>
Date: Thu Aug 24 12:27:20 2017 -0400

    manila: set "host" to "hostgroup"

    when running manila-share under control of pacemaker, as
    is done for cinder-volume service in the same circumstance.

    Change-Id: Ic97f01913bae2a388c962a38fa175eb1d763cdcb
    Depends-On: Ie31f2d5ccf458f5fcfe8bec5f2c37f45070cfde2
    Closes-Bug: #1712842
    (cherry picked from commit 8fa6c6e58c7ac0d32bf2f0dfb586683cf006e3bf)
    (cherry picked from commit 1f3cb179b8e668f9a4e2c2307b60b4ceecd877f4)

tags: added: in-stable-ocata

Reviewed: https://review.openstack.org/508117
Committed: https://git.openstack.org/cgit/openstack/tripleo-heat-templates/commit/?id=657e3479405e9c5ae86270ded7c58d7c13e5f4a2
Submitter: Jenkins
Branch: stable/newton

commit 657e3479405e9c5ae86270ded7c58d7c13e5f4a2
Author: Tom Barron <email address hidden>
Date: Thu Aug 24 12:27:20 2017 -0400

    manila: set "host" to "hostgroup"

    when running manila-share under control of pacemaker, as
    is done for cinder-volume service in the same circumstance.

    Change-Id: Ic97f01913bae2a388c962a38fa175eb1d763cdcb
    Depends-On: Ie31f2d5ccf458f5fcfe8bec5f2c37f45070cfde2
    Closes-Bug: #1712842
    (cherry picked from commit 8fa6c6e58c7ac0d32bf2f0dfb586683cf006e3bf)
    (cherry picked from commit 1f3cb179b8e668f9a4e2c2307b60b4ceecd877f4)
    (cherry picked from commit 87d4bdf6932f6e10867d6c3ae4717c25e9ad93a4)

tags: added: in-stable-newton

This issue was fixed in the openstack/tripleo-heat-templates 6.2.3 release.

This issue was fixed in the openstack/tripleo-heat-templates 5.3.3 release.

This issue was fixed in the openstack/tripleo-heat-templates 8.0.0.0b1 development milestone.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers