tripleo quickstart fails with "Failed to parse dlrn hash"

Bug #1712785 reported by Matthias Runge on 2017-08-24
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
tripleo
High
Unassigned

Bug Description

oooq called with

bash devmode.sh --no-gate --ovb -d -w /var/tmp/tripleo_rdo/

fails with
Thursday 24 August 2017 12:10:11 +0200 (0:00:15.851) 0:04:58.544 *******
included: /home/mrunge/work/tripleo-quickstart/roles/repo-setup/tasks/setup_repos.yml for undercloud

TASK [repo-setup : Setup repos on live host] ***********************************
task path: /home/mrunge/work/tripleo-quickstart/roles/repo-setup/tasks/setup_repos.yml:1
Thursday 24 August 2017 12:10:11 +0200 (0:00:00.091) 0:04:58.635 *******

.....

/yum/repos/x86_64/7/updates-source", "2017-08-24 10:10:23 | pkgdir = /var/cache/yum/x86_64/7/updates-source/packages", "2017-08-24 10:10:23 | priority = 99", "2017-08-24 10:10:23 | proxy = False", "2017-08-24 10:10:23 | proxy_dict = ", "2017-08-24 10:10:23 | proxy_password = ", "2017-08-24 10:10:23 | proxy_username = ", "2017-08-24 10:10:23 | repo_gpgcheck = False", "2017-08-24 10:10:23 | retries = 10", "2017-08-24 10:10:23 | skip_if_unavailable = False", "2017-08-24 10:10:23 | ssl_check_cert_permissions = True", "2017-08-24 10:10:23 | sslcacert = ", "2017-08-24 10:10:23 | sslclientcert = ", "2017-08-24 10:10:23 | sslclientkey = ", "2017-08-24 10:10:23 | sslverify = True", "2017-08-24 10:10:23 | throttle = 0", "2017-08-24 10:10:23 | timeout = 30.0", "2017-08-24 10:10:23 | ui_id = updates-source/7", "2017-08-24 10:10:23 | ui_repoid_vars = releasever,", "2017-08-24 10:10:23 | basearch", "2017-08-24 10:10:23 | username = ", "2017-08-24 10:10:23 | ", "2017-08-24 10:10:23 | + sudo rm -rf '/etc/yum.repos.d/delorean*'", "2017-08-24 10:10:23 | + sudo rm -rf '/etc/yum.repos.d/*.rpmsave'", "2017-08-24 10:10:23 | + '[' -e /etc/ci/mirror_info.sh ']'", "2017-08-24 10:10:23 | + export NODEPOOL_CENTOS_MIRROR=http://mirror.centos.org/centos", "2017-08-24 10:10:23 | + NODEPOOL_CENTOS_MIRROR=http://mirror.centos.org/centos", "2017-08-24 10:10:23 | + export NODEPOOL_BUILDLOGS_CENTOS_PROXY=https://buildlogs.centos.org", "2017-08-24 10:10:23 | + NODEPOOL_BUILDLOGS_CENTOS_PROXY=https://buildlogs.centos.org", "2017-08-24 10:10:23 | + export NODEPOOL_RDO_PROXY=http://trunk.rdoproject.org", "2017-08-24 10:10:23 | + NODEPOOL_RDO_PROXY=http://trunk.rdoproject.org", "2017-08-24 10:10:23 | ++ curl --silent http://trunk.rdoproject.org/centos7/current/delorean.repo", "2017-08-24 10:10:23 | ++ grep baseurl", "2017-08-24 10:10:23 | ++ cut -d= -f2", "2017-08-24 10:10:24 | + rdo_dlrn=", "2017-08-24 10:10:24 | ++ curl --silent http://trunk.rdoproject.org/centos7/current-tripleo/delorean.repo", "2017-08-24 10:10:24 | ++ grep baseurl", "2017-08-24 10:10:24 | ++ cut -d= -f2", "2017-08-24 10:10:24 | + tripleo_dlrn=", "2017-08-24 10:10:24 | + [[ -z '' ]]", "2017-08-24 10:10:24 | + echo 'Failed to parse dlrn hash'", "2017-08-24 10:10:24 | Failed to parse dlrn hash", "2017-08-24 10:10:24 | + exit 1"], "warnings": []}

Matthias Runge (mrunge) on 2017-08-24
tags: added: quickstart
Matthias Runge (mrunge) wrote :

reverting the mentioned patch makes it pass.

Changed in tripleo:
status: New → Confirmed
Paul Belanger (pabelanger) wrote :

This looks to be a networking issue, it seems to be failing on the curl to https://trunk.rdoproject.org/centos7/current/delorean.repo

John Trowbridge (trown) on 2017-08-24
Changed in tripleo:
importance: Undecided → High
milestone: none → pike-rc1
John Trowbridge (trown) wrote :

trying out 497215, since that would be way better than a full revert. I ran the original patch on libvirt and it worked, so the issue must be specific to rdo-cloud.

Matthias Runge (mrunge) wrote :

It also fails on ovb mode in my local setup.

Reviewed: https://review.openstack.org/497215
Committed: https://git.openstack.org/cgit/openstack/tripleo-quickstart/commit/?id=54039b9a10a4008ff07f77546f7869abe00d096d
Submitter: Jenkins
Branch: master

commit 54039b9a10a4008ff07f77546f7869abe00d096d
Author: Paul Belanger <email address hidden>
Date: Thu Aug 24 07:52:08 2017 -0400

    Use https for NODEPOOL_RDO_PROXY outside of gate

    When we changes this in Ia06ebad96c8db2a4eb732e80f04c72ad4c9bc6a3 we
    switch from https to http. Change this back to https.

    Change-Id: I8034cc49a9834cc0c1be35ea1fb1b14e4eae3fc6
    Related-Bug: #1712785
    Signed-off-by: Paul Belanger <email address hidden>

Changed in tripleo:
milestone: pike-rc1 → pike-rc2
Changed in tripleo:
status: Confirmed → Triaged
Changed in tripleo:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers