CI: OVB cloud doesn't provide stacks for jobs

Bug #1711913 reported by Sagi (Sergey) Shnaidman on 2017-08-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Critical
Sagi (Sergey) Shnaidman

Bug Description

2017-08-20 12:51:19.245704 | Installing collected packages: docutils, lockfile, python-daemon, gear
2017-08-20 12:51:19.764054 | Successfully installed docutils-0.14 gear-0.9.1 lockfile-0.12.2 python-daemon-2.1.2
2017-08-20 12:51:19.917601 | +(/opt/stack/new/tripleo-ci/toci_gate_test.sh:214): NETISO_ENV=multi-nic
2017-08-20 12:51:19.917751 | +(/opt/stack/new/tripleo-ci/toci_gate_test.sh:217): ./testenv-client -b 192.168.103.254:4730 -t 10200 --envsize 4 --ucinstance 37bc86c8-84bc-48b6-a913-9472f2595b6f --net-iso multi-nic -- ./toci_quickstart.sh
2017-08-20 12:51:19.917799 | +(/opt/stack/new/tripleo-ci/toci_gate_test.sh:211): sleep 1200
2017-08-20 12:54:49.177172 | 2017-08-20 12:54:49,174 - testenv-client - INFO - Received job : Couldn't retrieve env
2017-08-20 12:54:49.177272 | 2017-08-20 12:54:49,175 - testenv-client - WARNING - 209.2 seconds waiting for a worker.
2017-08-20 12:54:49.177318 | 2017-08-20 12:54:49,175 - testenv-client - ERROR - Couldn't retrieve env
2017-08-20 12:56:37.437946 | ERROR: the main setup script run by this job failed - exit code: 2
2017-08-20 12:56:37.438077 | please look at the relevant log files to determine the root cause
2017-08-20 12:56:37.438138 | Running devstack worlddump.py
2017-08-20 12:56:37.519524 | /bin/sh: brctl: command not found

http://logs.openstack.org/51/494151/2/check-tripleo/gate-tripleo-ci-centos-7-ovb-ha-oooq/dc832e4/console.html

Tags: ci Edit Tag help
description: updated

In te-broker it fails to update port:

++ neutron net-show -F id -f value provision-95756
+ nova interface-attach --net-id a1cecdc2-2232-43a3-89a0-d19a106ad196 0daf4249-9afa-470f-b5e8-9d30bff835ae
+ '[' multi-nic '!=' none ']'
++ neutron net-show -F id -f value public-95756
+ nova interface-attach --net-id 37bcda7e-64b6-494f-b15b-6531a432a212 0daf4249-9afa-470f-b5e8-9d30bff835ae
+ for PORT_SECURITY_NET in '$PROVISIONNET' '$PUBLICNET'
++ openstack port list --network provision-95756 --server 0daf4249-9afa-470f-b5e8-9d30bff835ae -f value -c ID
usage: openstack port list [-h] [-f {csv,json,table,value,yaml}] [-c COLUMN]
                           [--max-width <integer>] [--noindent]
                           [--quote {all,minimal,none,nonnumeric}]
                           [--device-owner <device-owner>] [--router <router>]
openstack port list: error: unrecognized arguments: --network provision-95756 --server 0daf4249-9afa-470f-b5e8-9d30bff835ae
+ neutron port-update --no-security-groups --port-security-enabled=False
usage: neutron port-update [-h] [--request-format {json}] [--name NAME]
                           [--description DESCRIPTION]
                           [--fixed-ip subnet_id=SUBNET,ip_address=IP_ADDR]
                           [--device-id DEVICE_ID]
                           [--device-owner DEVICE_OWNER]
                           [--admin-state-up {True,False}]
                           [--security-group SECURITY_GROUP | --no-security-groups]
                           [--extra-dhcp-opt EXTRA_DHCP_OPTS]
                           [--qos-policy QOS_POLICY | --no-qos-policy]
                           [--allowed-address-pair ip_address=IP_ADDR[,mac_address=MAC_ADDR]
                           | --no-allowed-address-pairs]
                           [--dns-name DNS_NAME | --no-dns-name]
                           PORT
neutron port-update: error: too few arguments
Try 'neutron help port-update' for more information.

https://github.com/openstack-infra/tripleo-ci/blob/4a8b331ce443c993b6415a3744e36dcede6399a3/scripts/te-broker/create-env#L115

wes hayutin (weshayutin) on 2017-08-20
Changed in tripleo:
milestone: none → pike-rc1
Ben Nemec (bnemec) wrote :

This is because http://git.openstack.org/cgit/openstack-infra/tripleo-ci/commit/?id=4a8b331ce443c993b6415a3744e36dcede6399a3 merged over the weekend, which added the new call to openstackclient that apparently isn't supported by the version that was running on the te-broker.

Updated the te-broker host and problem was solved.

tags: removed: alert
Changed in tripleo:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers