Upgrade failing with AnsibleUndefinedVariable: 'deploy_composable_scenario' is undefined

Bug #1710112 reported by Jiří Stránský on 2017-08-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Critical
Emilien Macchi

Bug Description

fatal: [undercloud]: FAILED! => {"changed": false, "failed": true, "msg": "AnsibleUndefinedVariable: 'deploy_composable_scenario' is undefined"}

http://logs.openstack.org/66/475366/15/check/gate-tripleo-ci-centos-7-containers-multinode-upgrades-nv/d7bd5d0/console.html

tags: added: alert

Fix proposed to branch: master
Review: https://review.openstack.org/492915

Changed in tripleo:
assignee: nobody → Jiří Stránský (jistr)
status: Triaged → In Progress
Changed in tripleo:
assignee: Jiří Stránský (jistr) → Emilien Macchi (emilienm)

Reviewed: https://review.openstack.org/492915
Committed: https://git.openstack.org/cgit/openstack/tripleo-quickstart/commit/?id=3fa2214be90ec844f181496c6c216423fdda345d
Submitter: Jenkins
Branch: master

commit 3fa2214be90ec844f181496c6c216423fdda345d
Author: Jiri Stransky <email address hidden>
Date: Fri Aug 11 11:07:42 2017 +0200

    Add missing deploy_composable_scenario in featuresets

    There were still a couple of featuresets that needed
    deploy_composable_scenario variable set, and it caused the upgrade CI
    job to start failing recently.

    As explained in commit message of change
    I7e7c13b9151607233f1159ed91c455dcec37e230 we were setting this
    variable elsewhere previously, but seems like we aren't doing that
    anymore.

    Change-Id: I8303a8d90a756512a8cfb0ac23984c58183138a2
    Closes-Bug: #1710112

Changed in tripleo:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers