When using network isolation, network subnet is not correctly set in ceph.conf

Bug #1709464 reported by Giulio Fidente on 2017-08-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
High
Giulio Fidente

Bug Description

In the overcloud nodes, when using network isolation and ceph-ansible, the public_network and cluster_network values in ceph.conf appear to be unresolved

public network = {u'get_attr': u'StorageSubnet', u'cidr': None}

Fix proposed to branch: master
Review: https://review.openstack.org/491886

Changed in tripleo:
assignee: nobody → Giulio Fidente (gfidente)
status: Confirmed → In Progress
Changed in tripleo:
milestone: none → pike-rc1

Reviewed: https://review.openstack.org/491886
Committed: https://git.openstack.org/cgit/openstack/tripleo-heat-templates/commit/?id=7d332c92a688112aa4e182e5d0df272ad98a527a
Submitter: Jenkins
Branch: master

commit 7d332c92a688112aa4e182e5d0df272ad98a527a
Author: Giulio Fidente <email address hidden>
Date: Tue Aug 8 21:00:30 2017 +0200

    Fix cidr get_attr in custom networks

    We were missing the square brackets around the list of arguments
    for get_attr when building the networks cidr output.

    This passed CI because Heat does not fail validation and Ceph (which
    is consuming the cidr output) is tested with a single network (ctlplane)
    which does not build the output using the same templates.

    Change-Id: I40bba0784a30295cb0d4eda1fbff20ebac85db99
    Closes-Bug: #1709464

Changed in tripleo:
status: In Progress → Fix Released

This issue was fixed in the openstack/tripleo-heat-templates 7.0.0.0rc1 release candidate.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers