upgrade to pike fails: major-upgrade-composable-steps-docker fails with Conflict: resources.InternalApiNetwork: Unable to create the flat network. Physical network internal_api is in use

Bug #1709105 reported by Sofer Athlan-Guyot on 2017-08-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Critical
Sofer Athlan-Guyot

Bug Description

Originally reported there https://bugzilla.redhat.com/show_bug.cgi?id=1478818 .

upgrade: major-upgrade-composable-steps-docker fails with Conflict: resources.InternalApiNetwork: Unable to create the flat network. Physical network internal_api is in use.

Digging a bit into the issue I notice that the InternalApiNetwork nested stack is CREATE_FAILED while the InternalNetwork nested stack is DELETE_FAILED:

(undercloud) [stack@undercloud-0 ~]$ openstack stack list --nested | grep -i network | grep -i internal
| 3d38bf53-6f78-4c5e-a5cc-304771eb3be4 | overcloud-Networks-5ofo6ltrxp7n-InternalApiNetwork-32zdrw34ckj2 | 0b9f9afc1f5a450da7c50b911c3e7f7f | CREATE_FAILED | 2017-08-07T11:50:21Z | None | 2d36d135-16c4-4e99-ab65-c1cac483725d |
| 697c7941-46fc-4172-ba90-a059ab72e6c4 | overcloud-Networks-5ofo6ltrxp7n-InternalNetwork-4xmk6d4rys2n | 0b9f9afc1f5a450da7c50b911c3e7f7f | DELETE_FAILED | 2017-08-05T20:08:25Z | None | 2d36d135-16c4-4e99-ab65-c1cac483725d |

The following change seems to be related:
https://review.openstack.org/#/c/475612/22/network/networks.j2.yaml

Changed in tripleo:
assignee: nobody → Sofer Athlan-Guyot (sofer-athlan-guyot)
status: Confirmed → In Progress

Change abandoned by Alex Schultz (<email address hidden>) on branch: master
Review: https://review.openstack.org/491510
Reason: Need to clear out the queue as this is going to fail. Will restore momentarily

Reviewed: https://review.openstack.org/491510
Committed: https://git.openstack.org/cgit/openstack/tripleo-heat-templates/commit/?id=a8a1d5b30c12a3cf8f0268216e97b9d2f7568086
Submitter: Jenkins
Branch: master

commit a8a1d5b30c12a3cf8f0268216e97b9d2f7568086
Author: Sofer Athlan-Guyot <email address hidden>
Date: Mon Aug 7 16:04:08 2017 +0200

    Keep dynamic network creation backward compatible.

    We had an history mapping for InternalApi to InternalNetwork. If we
    remove it then heat will want to destroy InternalNetwork and create
    InternalApi which cannot work during upgrade.

    This adds compat name parameters to network_data.yaml.

    Closes-Bug: #1709105

    Change-Id: I8ce6419a5e13a13ee6e991db5ca2196763f52d7a

Changed in tripleo:
status: In Progress → Fix Released

This issue was fixed in the openstack/tripleo-heat-templates 7.0.0.0rc1 release candidate.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers