Introspect/Provide Nodes buttons don't work in table view

Bug #1703820 reported by Ana Krivokapić
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Fix Released
Medium
Ana Krivokapić

Bug Description

Navigate to the nodes page and then to the table view. Introspect Nodes and Provide Nodes buttons in the table header are enabled even when no nodes are selected. Furthermore, clicking these buttons (both with selected nodes and when no nodes are selected) does not do anything.

Similarly, the Select All/Deselect All button does not work in table view.

Tags: ui ux
description: updated
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to tripleo-ui (master)

Fix proposed to branch: master
Review: https://review.openstack.org/487376

Changed in tripleo:
assignee: nobody → Ana Krivokapić (akrivoka)
status: Triaged → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to tripleo-ui (master)

Reviewed: https://review.openstack.org/487376
Committed: https://git.openstack.org/cgit/openstack/tripleo-ui/commit/?id=c5be597a75463101519bb52b8cba4b56f6f49685
Submitter: Jenkins
Branch: master

commit c5be597a75463101519bb52b8cba4b56f6f49685
Author: Ana Krivokapic <email address hidden>
Date: Wed Jul 26 13:38:32 2017 +0200

    Hide view switcher on Nodes page

    The table view on the nodes page is very buggy (see blueprint
    ui-rework-nodestableview). Hide it until the issue is addressed properly.
    The list view offers the same functionality as the table view, so
    users can use that in the meantime.

    Change-Id: I6269ac31556bc906bc8b5012b2e6d48f2c5c3a2e
    Partial-bug: #1703820

Changed in tripleo:
milestone: pike-3 → pike-rc1
Changed in tripleo:
milestone: pike-rc1 → queens-1
Revision history for this message
Alex Schultz (alex-schultz) wrote :

Is there anything else for this bug or can we close it out?

Revision history for this message
Ana Krivokapić (akrivoka) wrote :

It needs a proper fix - the patch above only hides the buttons in question.

Changed in tripleo:
milestone: queens-1 → queens-2
Revision history for this message
Liz Blanchard (lblanchard) wrote :

@Ana - Is this applicable anymore? Looks like the table view is no longer and we are just relying on List View where this does work.

Revision history for this message
Ana Krivokapić (akrivoka) wrote :

That depends on whether we want to bring the table view back eventually - my understanding is that we do.

If we do, then this issue is still valid and needs a proper fix - see above.
If we don't, then we should delete all the code supporting the table view from the code base.

In any case, there's still work to be done wrt this bug.

Revision history for this message
Liz Blanchard (lblanchard) wrote :

@Ana, Thanks for the extra info! From a UX point of view I'm in support of reviewing the Table view code completely. The List View supports all of the use cases needed. Would be interested in what others think.

tags: added: ux
Changed in tripleo:
milestone: queens-2 → queens-3
Changed in tripleo:
milestone: queens-3 → queens-rc1
Changed in tripleo:
milestone: queens-rc1 → rocky-1
Changed in tripleo:
milestone: rocky-1 → rocky-2
Changed in tripleo:
milestone: rocky-2 → rocky-3
Changed in tripleo:
milestone: rocky-3 → rocky-rc1
Changed in tripleo:
milestone: rocky-rc1 → stein-1
Changed in tripleo:
milestone: stein-1 → stein-2
Changed in tripleo:
milestone: stein-2 → stein-3
Changed in tripleo:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related blueprints