neutron-ovs-agent container constantly restarting with default configuration

Bug #1699261 reported by Brent Eagles
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Fix Released
Critical
Steve Baker

Bug Description

By default, the neutron-ovs-agent is configured with br-ex as part of the bridge mappings but the OVS bridge isn't actually being created on the host. This causes the container to go into a terminate/restart loop.

Brent Eagles (beagles)
Changed in tripleo:
status: New → Triaged
importance: Undecided → High
milestone: none → pike-3
Revision history for this message
Steven Hardy (shardy) wrote :
Changed in tripleo:
milestone: pike-3 → pike-rc1
Changed in tripleo:
assignee: nobody → Steve Baker (steve-stevebaker)
Revision history for this message
Steve Baker (steve-stevebaker) wrote :

Lets use bug #1691403 to track this, since it has more fix attempts.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to tripleo-heat-templates (master)

Fix proposed to branch: master
Review: https://review.openstack.org/493695

Changed in tripleo:
status: Triaged → In Progress
Changed in tripleo:
importance: High → Critical
Revision history for this message
Ben Nemec (bnemec) wrote :

Okay, the other bug got marked as a duplicate of this one for some reason. Re-adding the alert to it.

tags: added: alert containers networking
tags: removed: alert
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on tripleo-heat-templates (master)

Change abandoned by Emilien Macchi (<email address hidden>) on branch: master
Review: https://review.openstack.org/493695
Reason: I need to purge the gate because TripleO CI gate has critical issues right now, I'll make this patch goes to the gate.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to tripleo-heat-templates (master)

Reviewed: https://review.openstack.org/493695
Committed: https://git.openstack.org/cgit/openstack/tripleo-heat-templates/commit/?id=76f130d6e8f7434433b2602af9794f1e9c742e1f
Submitter: Jenkins
Branch: master

commit 76f130d6e8f7434433b2602af9794f1e9c742e1f
Author: Steve Baker <email address hidden>
Date: Tue Aug 15 10:26:24 2017 +1200

    container ovs-agent, ensure br-ex exists

    Currently the container neutron-ovs-agent is stuck in a restart loop
    in many environments because the bridge br-ex is missing.

    This bridge is created by running the puppet class
    neutron::agents::ml2::ovs but limiting that run to tag
    neutron::plugins::ovs::bridge.

    The hiera neutron::agents::ml2::ovs::bridge_mappings should already
    exists to create the bridge with the required settings.

    This change should ensure br-ex exists after step 3.

    Since br-ex is created regardless of the chosen network config,
    environments/docker-network.yaml is not longer required. It can be
    deleted once there are no more references to it in CI and
    documentation.

    Change-Id: Ie425148b0ad0f38e149c5fa0a97d98ec35d0a5bb
    Closes-Bug: #1699261
    Closes-Bug: #1691403
    Closes-Bug: #1689556

Changed in tripleo:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to tripleo-heat-templates (stable/pike)

Fix proposed to branch: stable/pike
Review: https://review.openstack.org/499137

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to tripleo-heat-templates (stable/pike)

Reviewed: https://review.openstack.org/499137
Committed: https://git.openstack.org/cgit/openstack/tripleo-heat-templates/commit/?id=0f2af352d15cb9c486414619a8342e727a2e207c
Submitter: Jenkins
Branch: stable/pike

commit 0f2af352d15cb9c486414619a8342e727a2e207c
Author: Steve Baker <email address hidden>
Date: Tue Aug 15 10:26:24 2017 +1200

    container ovs-agent, ensure br-ex exists

    Currently the container neutron-ovs-agent is stuck in a restart loop
    in many environments because the bridge br-ex is missing.

    This bridge is created by running the puppet class
    neutron::agents::ml2::ovs but limiting that run to tag
    neutron::plugins::ovs::bridge.

    The hiera neutron::agents::ml2::ovs::bridge_mappings should already
    exists to create the bridge with the required settings.

    This change should ensure br-ex exists after step 3.

    Since br-ex is created regardless of the chosen network config,
    environments/docker-network.yaml is not longer required. It can be
    deleted once there are no more references to it in CI and
    documentation.

    Change-Id: Ie425148b0ad0f38e149c5fa0a97d98ec35d0a5bb
    Closes-Bug: #1699261
    Closes-Bug: #1691403
    Closes-Bug: #1689556
    (cherry picked from commit 76f130d6e8f7434433b2602af9794f1e9c742e1f)

tags: added: in-stable-pike
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/tripleo-heat-templates 7.0.0.0rc2

This issue was fixed in the openstack/tripleo-heat-templates 7.0.0.0rc2 release candidate.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/tripleo-heat-templates 8.0.0.0b1

This issue was fixed in the openstack/tripleo-heat-templates 8.0.0.0b1 development milestone.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers