octavia-api can't be separated from neutron-server

Bug #1687026 reported by Emilien Macchi on 2017-04-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Medium
Emilien Macchi

Bug Description

If you try to deploy Octavia API and Neutron Server on different hosts, Neutron Server won't load the Octavia service provider because the hiera parameter is not loaded for the neutron service, but just for octavia.

It's a bug in the composable services.

Changed in tripleo:
milestone: none → pike-3

Fix proposed to branch: master
Review: https://review.openstack.org/461056

Changed in tripleo:
status: Triaged → In Progress

Reviewed: https://review.openstack.org/461056
Committed: https://git.openstack.org/cgit/openstack/tripleo-heat-templates/commit/?id=4d0dfd810c5516b0509fa891184476f47f2eb52d
Submitter: Jenkins
Branch: master

commit 4d0dfd810c5516b0509fa891184476f47f2eb52d
Author: Emilien Macchi <email address hidden>
Date: Fri Apr 28 10:09:44 2017 -0400

    Allow to deploy Octavia API & Neutron Server on 2 different nodes

    Exporting the neutron::server parameter into the neutron_api service, so
    Octavia API and Neutron Server can be separated.

    Change-Id: Iee28b0e84a00bd589d6f14a73f0c3f32d310b393
    Closes-Bug: #1687026

Changed in tripleo:
status: In Progress → Fix Released

This issue was fixed in the openstack/tripleo-heat-templates 7.0.0.0b2 development milestone.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers