container puppet -- fails to curl rabbitmqadmin from rabbitmq

Bug #1684104 reported by Jiří Stránský on 2017-04-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Low
Unassigned

Bug Description

I've seen this error during upgrade from non-containers to containers:

Apr 19 10:50:53 centos-7-2-node-infracloud-vanilla-8482220-534323 os-collect-config: #033[1;31m

Error:

 curl -k --retry 30 --retry-delay 6 -f -L -o /var/lib/rabbitmq/rabbitmqadmin http://guest:WuWEPrxHqjAqXgc3dnVGUueFN@127.0.0.1:15672/cli/rabbitmqadmin returned 7 instead of one of [0]#033[0m
Apr 19 10:50:53 centos-7-2-node-infracloud-vanilla-8482220-534323 os-collect-config: #033[1;31mError: /Stage[main]/Rabbitmq::Install::Rabbitmqadmin/Staging::File[rabbitmqadmin]/Exec[/var/lib/rabbitmq/rabbitmqadmin]/returns: change from notrun to 0 failed: curl -k --retry 30 --retry-delay 6 -f -L -o /var/lib/rabbitmq/rabbitmqadmin http://guest:WuWEPrxHqjAqXgc3dnVGUueFN@127.0.0.1:15672/cli/rabbitmqadmin returned 7 instead of one of [0]#033[0m

http://logs.openstack.org/84/450784/15/experimental/gate-tripleo-ci-centos-7-containers-multinode-upgrades-nv/823dfd7/logs/subnode-2/var/log/messages.txt.gz#_Apr_19_10_50_53

Martin André (mandre) wrote :

Could this be a duplicate of bug 1684044?

Jiří Stránský (jistr) wrote :

It doesn't look like a duplicate of bug 1684044 to me.

This curl bug looks like a chicken-and-egg problem. The puppet container is trying to connect to rabbitmq, but it's not running yet (how could it, when it doesn't have configs generated yet, which is the job of this puppet container :D).

Bogdan Dobrelya (bogdando) wrote :

It may be a dup of https://bugs.launchpad.net/tripleo/+bug/1684075 then, or rather a sub case of it

Jiří Stránský (jistr) wrote :

It looks like this is not an error which actually causes the deployment/upgrade to fail, so i'm setting the prio to low.

Changed in tripleo:
importance: High → Low

Reviewed: https://review.openstack.org/458119
Committed: https://git.openstack.org/cgit/openstack/tripleo-heat-templates/commit/?id=73651aa9bbcf64af0529185d9abb81d1762a976b
Submitter: Jenkins
Branch: master

commit 73651aa9bbcf64af0529185d9abb81d1762a976b
Author: Jiri Stransky <email address hidden>
Date: Wed Apr 19 17:02:15 2017 +0200

    Containers: disable downloading rabbitmqadmin

    There's no need for puppet to download rabbitmqadmin script from
    rabbitmq, as the script would be immediately deleted together with the
    ephemeral puppet container. Also, since rabbitmq isn't running at the
    time we run the puppet container (rabbitmq doesn't have config files
    generated at that point), puppet couldn't connect to rabbitmq anyway.

    Change-Id: Ia59e1013c24ab02037246135024418cc9b674606
    Closes-Bug: #1684104

Changed in tripleo:
status: Triaged → Fix Released

This issue was fixed in the openstack/tripleo-heat-templates 7.0.0.0b2 development milestone.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers