[promotion] nova hypervisors/detail fails when host is not mapped to any cell

Bug #1682001 reported by Emilien Macchi on 2017-04-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
High
Dan Smith
tripleo
Critical
Oliver Walsh

Bug Description

Changed in tripleo:
importance: Undecided → Critical
status: New → Triaged
milestone: none → pike-2
tags: added: alert ci promotion-blocker
Oliver Walsh (owalsh) wrote :

This is occurring when the undercloud mistral action is querying the API for the ironic uuid:
http://logs.openstack.org/15/359215/85/check-tripleo/gate-tripleo-ci-centos-7-ovb-ha/0040e01/console.html#_2017-04-12_04_11_12_148310

We don't expect a HostMapping to exist at this point. This occurs before we run discover hosts.

Oliver Walsh (owalsh) on 2017-04-12
summary: - [promotion] nova fails to start a server - host is not mapped to any
+ [promotion] nova hypervisors/detail fails when host is not mapped to any
cell

Related fix proposed to branch: master
Review: https://review.openstack.org/456261

Changed in tripleo:
assignee: nobody → Oliver Walsh (owalsh)
status: Triaged → In Progress

Change abandoned by Emilien Macchi (<email address hidden>) on branch: master
Review: https://review.openstack.org/456261
Reason: In favor of https://review.openstack.org/#/c/456696/

Reviewed: https://review.openstack.org/456227
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=370820ba52629c9de5046d616a63da904fdaa014
Submitter: Jenkins
Branch: master

commit 370820ba52629c9de5046d616a63da904fdaa014
Author: Dan Smith <email address hidden>
Date: Wed Apr 12 07:25:30 2017 -0700

    Fix hypervisors api missing HostMappingNotFound handlers

    In If1e03c9343b8cc9c34bd51c2b4d25acdb21131ff we missed a few places
    where HostMappingNotFound can not be raised. This adds those and
    tests to cover them.

    Change-Id: Ia7240c2aeb4ecb512eda37bc3007f9d16534a5d3
    Related-Bug: #1682001

Reviewed: https://review.openstack.org/456696
Committed: https://git.openstack.org/cgit/openstack/tripleo-common/commit/?id=8386160c7b20b6ddb72f083863a8c0057a62edb3
Submitter: Jenkins
Branch: master

commit 8386160c7b20b6ddb72f083863a8c0057a62edb3
Author: Oliver Walsh <email address hidden>
Date: Wed Apr 12 16:22:52 2017 +0100

    Fix undercloud host discovery logic.

    We previously spun until the ironic hosts are returned by the API then ran
    discover_host once (creates host mappings).

    Since If1e03c9343b8cc9c34bd51c2b4d25acdb21131ff the ironic hosts will not be
    returned by the nova API until the host mappings exists.

    This patch changes the logic to run discovery hosts and then check the API,
    and spin until both tasks succeed.

    This is a duplicate of I47a190a10ebef8eb8c2c4150635dca1c80c6cda0,
    with a different depends-on as I suspect we can merge without the nova fix.

    Change-Id: I10e23417417df03e1b0f78e060ba1451334a0bc6
    Depends-On: If1e03c9343b8cc9c34bd51c2b4d25acdb21131ff
    Closes-Bug: #1682001

Changed in tripleo:
status: In Progress → Fix Released
Matt Riedemann (mriedem) on 2017-04-14
Changed in nova:
status: New → Fix Released
importance: Undecided → High
assignee: nobody → Dan Smith (danms)

This issue was fixed in the openstack/tripleo-common 7.0.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers