Default Deployment of v3 Endpoint Causes Issues with Horizon

Bug #1675075 reported by Dustin Schoenbrun on 2017-03-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
High
Unassigned

Bug Description

When you log in to the Horizon UI as either the admin user or a "regular" user after a TripleO deployment there are several issues having to do with Horizon being configured to use a Keystone v3 endpoint but only being provided a v2 endpoint. With the Manila Horizon UI plugin, it causes the Create Share button to not be visible along with a multitude of errors in Horizon's logs.

This appears to affect at least Ocata bits, but might also have impact in Pike.

Steps to Reproduce:
1) Install an OpenStack instance using TripleO, ensuring that Horizon is installed along with the Manila Horizon UI Plugin (not required, but this is how I found the bug).
2) Create a non-privileged user in the Overcloud for use in Horizon.
3) Log in to the Horizon UI using the non-privileged user created in Step 2.
4) Navigate to the Shares section in the Horizon UI and click on the Shares tab.
5) Observe that the "Create Share" button is not visible (and is not hidden).

Emilien Macchi (emilienm) wrote :

I'm not sure it affects Pike, since we are now deploying Keystone versionless endpoints, so Keystone v3 is discoverable.

Changed in tripleo:
status: New → Triaged
importance: Undecided → High
milestone: none → pike-1
tags: added: ocata-backport-potential

Change abandoned by Tom Barron (<email address hidden>) on branch: stable/ocata
Review: https://review.openstack.org/449027
Reason: Use https://review.openstack.org/#/c/448614 instead.

Changed in tripleo:
milestone: pike-1 → pike-2
Changed in tripleo:
milestone: pike-2 → pike-3
Changed in tripleo:
milestone: pike-3 → pike-rc1
Ben Nemec (bnemec) wrote :

According to the comments on https://review.openstack.org/#/c/448614 this is fixed.

Changed in tripleo:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers