Nodes registration like never ends until window is refreshed

Bug #1672826 reported by opavlenk on 2017-03-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Medium
Dan Trainor

Bug Description

Nodes registration seems never end until the page is refreshed

Steps to Reproduce:
1. upload instackenv.json
2. click on register
3. wait for nodes table to view new registered nodes

Actual results:
nodes registration spin forever until the page refreshed

Expected results:
after new nodes were registered, registered nodes table is shown with each nodes' statuses

Additional info:
while nodes registration still "in progress" on UI , in CLI , nodes info already available:

Changed in tripleo:
milestone: none → pike-1
importance: Undecided → Medium
status: New → Triaged
Dan Trainor (dtrainor) on 2017-03-30
Changed in tripleo:
assignee: nobody → Dan Trainor (dtrainor)

Fix proposed to branch: master
Review: https://review.openstack.org/452017

Changed in tripleo:
status: Triaged → In Progress

Reviewed: https://review.openstack.org/452017
Committed: https://git.openstack.org/cgit/openstack/puppet-tripleo/commit/?id=e8125cb3640e0fe74b8617aaf55686d5645c8f7f
Submitter: Jenkins
Branch: master

commit e8125cb3640e0fe74b8617aaf55686d5645c8f7f
Author: Dan Trainor <email address hidden>
Date: Thu Mar 30 20:36:04 2017 -0400

    Add tunnel timeout for ui proxy container

    Add an explicit tunnel timeout configuration option to increase the
    tunnel timeout for persistent socket connections from two minutes (2m)
    to one hour (3600s). A configuration was already present to apply a
    tunnel timeout to the zaqar_ws endpoint, but that only applies to
    connections made directly to the zaqar_ws endpoint directly. Since UI
    now uses mod_proxy to proxy WebSocket connections for Zaqar, the timeout
    is now applied for the same reasons to the ui haproxy server.

    Change-Id: If749dc9148ccf8f2fa12b56b6ed6740f42e65aeb
    Closes-Bug: 1672826

Changed in tripleo:
status: In Progress → Fix Released
Jiri Tomasek (jtomasek) on 2017-04-04
tags: added: ocata-backport-potential

Reviewed: https://review.openstack.org/453468
Committed: https://git.openstack.org/cgit/openstack/tripleo-ui/commit/?id=51939de19bdf05d6308dd4cf50cf3714497bc89e
Submitter: Jenkins
Branch: master

commit 51939de19bdf05d6308dd4cf50cf3714497bc89e
Author: Jiri Tomasek <email address hidden>
Date: Wed Apr 5 13:07:43 2017 +0200

    Add not set value to ports filtering in selector

    This change prevents errors when listing Nodes with ports
    when portsDetail property is not set

    Partial-bug: 1671131
    Closes-Bug: 1672826
    Change-Id: I5c703c7ee8fc45bc0c574af6de1217dbf3370027

Reviewed: https://review.openstack.org/453743
Committed: https://git.openstack.org/cgit/openstack/tripleo-ui/commit/?id=a26f66b0ba30eac98ac3ca3e1e835e4cdcf5ac7b
Submitter: Jenkins
Branch: stable/ocata

commit a26f66b0ba30eac98ac3ca3e1e835e4cdcf5ac7b
Author: Jiri Tomasek <email address hidden>
Date: Wed Apr 5 13:07:43 2017 +0200

    Add not set value to ports filtering in selector

    This change prevents errors when listing Nodes with ports
    when portsDetail property is not set

    Partial-bug: 1671131
    Closes-Bug: 1672826
    Change-Id: I5c703c7ee8fc45bc0c574af6de1217dbf3370027
    (cherry picked from commit 51939de19bdf05d6308dd4cf50cf3714497bc89e)

tags: added: in-stable-ocata

Reviewed: https://review.openstack.org/453127
Committed: https://git.openstack.org/cgit/openstack/puppet-tripleo/commit/?id=b1b418d2a4d39f263899770b3e7e3a07cca2a1b6
Submitter: Jenkins
Branch: stable/ocata

commit b1b418d2a4d39f263899770b3e7e3a07cca2a1b6
Author: Dan Trainor <email address hidden>
Date: Thu Mar 30 20:36:04 2017 -0400

    Add tunnel timeout for ui proxy container

    Add an explicit tunnel timeout configuration option to increase the
    tunnel timeout for persistent socket connections from two minutes (2m)
    to one hour (3600s). A configuration was already present to apply a
    tunnel timeout to the zaqar_ws endpoint, but that only applies to
    connections made directly to the zaqar_ws endpoint directly. Since UI
    now uses mod_proxy to proxy WebSocket connections for Zaqar, the timeout
    is now applied for the same reasons to the ui haproxy server.

    Change-Id: If749dc9148ccf8f2fa12b56b6ed6740f42e65aeb
    Closes-Bug: 1672826
    (cherry picked from commit e8125cb3640e0fe74b8617aaf55686d5645c8f7f)

This issue was fixed in the openstack/puppet-tripleo 7.0.0 release.

This issue was fixed in the openstack/tripleo-ui 7.0.0 release.

This issue was fixed in the openstack/puppet-tripleo 6.4.0 release.

This issue was fixed in the openstack/tripleo-ui 3.2.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers