Newton->Ocata upgrade fails during neutron-db-manage upgrade head (caused by python-networking-odl)

Bug #1663219 reported by Marius Cornea on 2017-02-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
networking-odl
Undecided
Unassigned
tripleo
Critical
Brent Eagles

Bug Description

[root@overcloud-controller-0 ~]# rpm -qa | grep networking-odl
python-networking-odl-3.2.1-0.20170112221316.74b6165.el7.centos.noarch

[root@overcloud-controller-0 ~]# neutron-db-manage --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugin.ini upgrade head
INFO [alembic.runtime.migration] Context impl MySQLImpl.
INFO [alembic.runtime.migration] Will assume non-transactional DDL.
  Running upgrade for neutron ...
INFO [alembic.runtime.migration] Context impl MySQLImpl.
INFO [alembic.runtime.migration] Will assume non-transactional DDL.
  OK
Traceback (most recent call last):
  File "/bin/neutron-db-manage", line 10, in <module>
    sys.exit(main())
  File "/usr/lib/python2.7/site-packages/neutron/db/migration/cli.py", line 687, in main
    return_val |= bool(CONF.command.func(config, CONF.command.name))
  File "/usr/lib/python2.7/site-packages/neutron/db/migration/cli.py", line 206, in do_upgrade
    run_sanity_checks(config, revision)
  File "/usr/lib/python2.7/site-packages/neutron/db/migration/cli.py", line 671, in run_sanity_checks
    script_dir.run_env()
  File "/usr/lib/python2.7/site-packages/alembic/script/base.py", line 407, in run_env
    util.load_python_file(self.dir, 'env.py')
  File "/usr/lib/python2.7/site-packages/alembic/util/pyfiles.py", line 93, in load_python_file
    module = load_module_py(module_id, path)
  File "/usr/lib/python2.7/site-packages/alembic/util/compat.py", line 79, in load_module_py
    mod = imp.load_source(module_id, path, fp)
  File "/usr/lib/python2.7/site-packages/networking_odl/db/migration/alembic_migrations/env.py", line 26, in <module>
    from neutron.db import model_base
ImportError: cannot import name model_base

Marius Cornea (mcornea) on 2017-02-09
summary: Newton->Ocata upgrade fails during neutron-db-manage upgrade head
- (caused by python-networking-bigswitch)
+ (caused by python-networking-odl)
Brent Eagles (beagles) wrote :

https://review.openstack.org/#/c/401041/ may have fixed this. It was merged some time ago however so we may need to poke the packagers on this.

Brent Eagles (beagles) on 2017-02-09
Changed in tripleo:
assignee: nobody → Brent Eagles (beagles)
Brent Eagles (beagles) wrote :

Seems to be a package version. 3.2.1 on newton and 3.1.1 for master/ocata so the package isn't getting updated with fixes made in 3.1.1

Brent Eagles (beagles) wrote :

FWIW, considering that this particular case is specific to an ODL package version number, I'm not sure that this should impact TripleO RC1 as it's really on the networking-ODL packagers to straighten out.

Isaku Yamahata (yamahata) wrote :

networking-odl 3.x.x is newton release. Not ocata.
Please use source tree corresponging to ocata release.

The request to cut stable/ocata branch is at https://review.openstack.org/#/c/434465/
Once it is merged, networking-odl has stable/ocata branch. Please use that branch. (or master branch until cutting it.)

Changed in networking-odl:
status: New → Invalid
Isaku Yamahata (yamahata) wrote :

btw networking-odl ocata will have the version of 4.x.x

Changed in tripleo:
milestone: ocata-rc1 → ocata-rc2
Brent Eagles (beagles) wrote :

Ocata/master patch has been updated with version 4.0.1. This should get us a little farther along. Marius can you retest?

Changed in tripleo:
status: Triaged → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers