CI: promoted overcloud-full image is missing from the mirror

Bug #1661656 reported by Gabriele Cerami on 2017-02-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Critical
Unassigned

Bug Description

Currently there's no overcloud promoted image in the mirror, so the gates are rebuilding the overcloud image every time.
Something went wrong during today's promotion.

Tags: ci Edit Tag help
summary: - CI: promoted overcloud-full image is missing in the mirror
+ CI: promoted overcloud-full image is missing from the mirror
Gabriele Cerami (gcerami) wrote :

Mirror server is out of storage space.

We've lost today's promoted image, so we'll have to kick another manual promotion after space is freed

Gabriele Cerami (gcerami) wrote :

some space was freed, and image from yesterday's promotion was copied over. Kicking a manual promotion now.

Ben Nemec (bnemec) on 2017-02-03
tags: removed: alert
Ben Nemec (bnemec) wrote :

The promotion job passed, so this has been resolved. Note that there was an issue with the image I copied over. Apparently it was an image for an older release (I'm not sure why it was on the mirror server, but whatever) and it broke jobs using the cached images for a period of time today.

Changed in tripleo:
status: Triaged → Fix Released
Gabriele Cerami (gcerami) wrote :

I see some new uploads in the mirror server, but the link to the current-tripleo was not updated. http://66.187.229.139/builds/current-tripleo/ still points to the ones you copied.
Perhaps it has something to do with the permissions on the files ?

Emilien Macchi (emilienm) wrote :

OVB jobs are timeouting because we still deploy Mitaka. Re-opening it.

Changed in tripleo:
status: Fix Released → Triaged
milestone: none → ocata-rc1
tags: added: alert

So such steps were made till now:

1) Renamed all files in directory current-tripleo and ran promotion job manually in order to get new correct images. It failed on ssh issue and reran it again.
2) Found that images weren't updated to master although they had master repos, fixing it in the patch: https://review.openstack.org/#/c/429713/

Emilien Macchi (emilienm) wrote :

Closing the bug, as we purged the old image and kick-ed off a promotion job, that built a new image.

Changed in tripleo:
status: Triaged → Fix Released
tags: removed: alert
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers