NetworkDeployment is executed even if NetworkDeploymentActions is set to ["CREATE"] only

Bug #1661412 reported by Emilien Macchi on 2017-02-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
High
Unassigned

Bug Description

How to reproduce:
- deploy TripleO Newton with OS::TripleO::Controller::Net::SoftwareConfig configured to:
https://github.com/openstack/tripleo-heat-templates/blob/stable/newton/ci/common/net-config-multinode.yaml
- upgrade to Ocata with OS::TripleO::Controller::Net::SoftwareConfig configured to:
https://github.com/openstack/tripleo-heat-templates/blob/master/ci/common/net-config-multinode-os-net-config.yaml

Actual results:
NetworkDeploymentActions seems to execute NetworkDeployment on stack-update and it fails.

http://logs.openstack.org/72/426372/8/experimental/gate-tripleo-ci-centos-7-scenario001-multinode-upgrades-nv/0203b17/console.html#_2017-02-02_20_37_23_403592

http://logs.openstack.org/72/426372/8/experimental/gate-tripleo-ci-centos-7-scenario001-multinode-upgrades-nv/0203b17/logs/var/log/heat/heat-engine.txt.gz#_2017-02-02_20_37_20_990

Expected results:
NetworkDeploymentActions should not be execute NetworkDeployment on stack-update.

Emilien Macchi (emilienm) wrote :

[INFO] {"deploy_stdout": "", "deploy_stderr": "RTNETLINK answers: File exists\n", "deploy_status_code": 2}

from http://logs.openstack.org/72/426372/8/experimental/gate-tripleo-ci-centos-7-scenario001-multinode-upgrades-nv/0203b17/logs/subnode-2/var/log/messages

Means some "ip" commands are run.

Reviewed: https://review.openstack.org/428747
Committed: https://git.openstack.org/cgit/openstack/tripleo-heat-templates/commit/?id=f48c66509984a29169a1437593b4e288f1eb506c
Submitter: Jenkins
Branch: master

commit f48c66509984a29169a1437593b4e288f1eb506c
Author: Emilien Macchi <email address hidden>
Date: Fri Feb 3 09:17:59 2017 -0500

    net-config-multinode: make controlplane int idempotent

    When doing a stack-update, it will try to create the control plane
    interface again.
    Add this conditional so the interface is not created if already exist.

    Note: this code has been taken from tripleo-ci and is consistent with
    how multinode jobs are currently tested.

    Co-Authored-By: James Slagle <email address hidden>
    Co-Authored-By: Steven Hardy <email address hidden>
    Co-Authored-By: Mathieu Bultel <email address hidden>

    Change-Id: I773fdf5359cead6961b595e3c8192b02406452b7
    Related-Bug: #1661412

Reviewed: https://review.openstack.org/428828
Committed: https://git.openstack.org/cgit/openstack/tripleo-heat-templates/commit/?id=d84fe0f9671825e371c18957d6992487175ea6ee
Submitter: Jenkins
Branch: stable/newton

commit d84fe0f9671825e371c18957d6992487175ea6ee
Author: Emilien Macchi <email address hidden>
Date: Fri Feb 3 09:17:59 2017 -0500

    net-config-multinode: make controlplane int idempotent

    When doing a stack-update, it will try to create the control plane
    interface again.
    Add this conditional so the interface is not created if already exist.

    Note: this code has been taken from tripleo-ci and is consistent with
    how multinode jobs are currently tested.

    Co-Authored-By: James Slagle <email address hidden>
    Co-Authored-By: Steven Hardy <email address hidden>
    Co-Authored-By: Mathieu Bultel <email address hidden>

    Change-Id: I773fdf5359cead6961b595e3c8192b02406452b7
    Related-Bug: #1661412
    (cherry picked from commit f48c66509984a29169a1437593b4e288f1eb506c)

tags: added: in-stable-newton
Changed in tripleo:
milestone: ocata-rc1 → ocata-rc2
Changed in tripleo:
milestone: ocata-rc2 → pike-1
Changed in tripleo:
milestone: pike-1 → pike-2
Changed in tripleo:
milestone: pike-2 → pike-3
Changed in tripleo:
milestone: pike-3 → pike-rc1
Ben Nemec (bnemec) wrote :

It looks like this was fixed, but the commit was marked Related-Bug instead of Closes-Bug.

Changed in tripleo:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers