All ovb jobs failing to set up snmp

Bug #1659384 reported by Ben Nemec on 2017-01-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Critical
Ben Nemec

Bug Description

Both the mitaka and newton jobs seem to be failing on an snmp setup issue in puppet. Sample output from a newton job:

2017-01-25 18:08:21.000 | Error: Could not set 'present' on ensure: No such file or directory - /etc/snmp/snmptrapd.conf20170125-32771-duo9mp.lock at 466:/etc/puppet/modules/snmp/manifests/init.pp
2017-01-25 18:08:21.000 | Error: Could not set 'present' on ensure: No such file or directory - /etc/snmp/snmptrapd.conf20170125-32771-duo9mp.lock at 466:/etc/puppet/modules/snmp/manifests/init.pp
2017-01-25 18:08:21.000 | Wrapped exception:
2017-01-25 18:08:21.000 | No such file or directory - /etc/snmp/snmptrapd.conf20170125-32771-duo9mp.lock
2017-01-25 18:08:21.000 | Error: /Stage[main]/Snmp/File[snmptrapd.conf]/ensure: change from absent to present failed: Could not set 'present' on ensure: No such file or directory - /etc/snmp/snmptrapd.conf20170125-32771-duo9mp.lock at 466:/etc/puppet/modules/snmp/manifests/init.pp

Full log: http://logs.openstack.org/09/421409/4/check-tripleo/gate-tripleo-ci-centos-7-ovb-nonha-newton/39e5b4e/logs/postci.txt.gz

Mitaka output looks a little different, but I think it's the same error.

Changed in tripleo:
milestone: ongoing → ocata-rc1
assignee: nobody → Ben Nemec (bnemec)

Fix proposed to branch: master
Review: https://review.openstack.org/425339

Changed in tripleo:
status: Triaged → In Progress
Ben Nemec (bnemec) wrote :
summary: - Stable jobs failing to set up snmp
+ All ovb jobs failing to set up snmp

Reviewed: https://review.openstack.org/425346
Committed: https://git.openstack.org/cgit/openstack/tripleo-puppet-elements/commit/?id=4dd3540c6a75cb7cc65fd3e7cd2ffba420ad158e
Submitter: Jenkins
Branch: stable/mitaka

commit 4dd3540c6a75cb7cc65fd3e7cd2ffba420ad158e
Author: Ben Nemec <email address hidden>
Date: Wed Jan 25 18:46:39 2017 +0000

    Add explicit install of net-snmp

    Suddenly net-snmp is missing on our mitaka and newton images. A
    dependency must have changed that stopped pulling it in. Since we
    require that package to be installed for the deployment to succeed,
    we should install it explicitly. This will need to be backported
    to those stable branches as well.

    Change-Id: Ic81a64ae625e7fe208e3cc7f452124724a42d01a
    Closes-Bug: 1659384
    (cherry picked from commit 688584c435cdfea11d0e37917a3f433205fef084)
    (cherry picked from commit d5fea4ae301947cd244315ba6614eb6dec608f00)

tags: added: in-stable-mitaka

Reviewed: https://review.openstack.org/425339
Committed: https://git.openstack.org/cgit/openstack/tripleo-puppet-elements/commit/?id=688584c435cdfea11d0e37917a3f433205fef084
Submitter: Jenkins
Branch: master

commit 688584c435cdfea11d0e37917a3f433205fef084
Author: Ben Nemec <email address hidden>
Date: Wed Jan 25 18:46:39 2017 +0000

    Add explicit install of net-snmp

    Suddenly net-snmp is missing on our mitaka and newton images. A
    dependency must have changed that stopped pulling it in. Since we
    require that package to be installed for the deployment to succeed,
    we should install it explicitly. This will need to be backported
    to those stable branches as well.

    Change-Id: Ic81a64ae625e7fe208e3cc7f452124724a42d01a
    Closes-Bug: 1659384

Changed in tripleo:
status: In Progress → Fix Released
Gabriele Cerami (gcerami) wrote :

Jobs continue to fail even though the net-snmp package is present.

Changed in tripleo:
status: Fix Released → In Progress
Gabriele Cerami (gcerami) wrote :

Ok, package is not present on the overcloud, only on the undercloud. Periodic jobs still fail

Reviewed: https://review.openstack.org/425343
Committed: https://git.openstack.org/cgit/openstack/tripleo-puppet-elements/commit/?id=d5fea4ae301947cd244315ba6614eb6dec608f00
Submitter: Jenkins
Branch: stable/newton

commit d5fea4ae301947cd244315ba6614eb6dec608f00
Author: Ben Nemec <email address hidden>
Date: Wed Jan 25 18:46:39 2017 +0000

    Add explicit install of net-snmp

    Suddenly net-snmp is missing on our mitaka and newton images. A
    dependency must have changed that stopped pulling it in. Since we
    require that package to be installed for the deployment to succeed,
    we should install it explicitly. This will need to be backported
    to those stable branches as well.

    Change-Id: Ic81a64ae625e7fe208e3cc7f452124724a42d01a
    Closes-Bug: 1659384
    (cherry picked from commit 688584c435cdfea11d0e37917a3f433205fef084)

tags: added: in-stable-newton
tags: removed: alert in-stable-newton
Gabriele Cerami (gcerami) wrote :

Change finally reached packaging. All working again now

Changed in tripleo:
status: In Progress → Fix Released

This issue was fixed in the openstack/tripleo-puppet-elements 5.2.1 release.

This issue was fixed in the openstack/tripleo-puppet-elements 6.0.0.0rc1 release candidate.

This issue was fixed in the openstack/tripleo-puppet-elements 3.2.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers