overcloud delete does not actually delete the overcloud

Bug #1657461 reported by Brad P. Crochet on 2017-01-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Critical
Brad P. Crochet

Bug Description

The 'openstack overcloud delete' command doesn't actually delete the overcloud. It just sits and waits for the stack to go to delete status without actually kicking off the delete.

Changed in tripleo:
status: Confirmed → Triaged
Alex Schultz (alex-schultz) wrote :

Looks like the stack.delete got nuked in an update. ttps://review.openstack.org/#/c/401024/3..6/tripleoclient/v1/overcloud_delete.py

Fix proposed to branch: master
Review: https://review.openstack.org/422250

Changed in tripleo:
assignee: Brad P. Crochet (brad-9) → Alex Schultz (alex-schultz)
status: Triaged → In Progress
Brad P. Crochet (brad-9) wrote :

I am moving this to a workflow as part of the fix. The current code won't work anyway, since the wait_for_stack_ready will fail, as the stack will just go away. It will never actually move to DELETE_COMPLETE.

Changed in tripleo:
assignee: Alex Schultz (alex-schultz) → Brad P. Crochet (brad-9)

Change abandoned by Alex Schultz (<email address hidden>) on branch: master
Review: https://review.openstack.org/422250

Reviewed: https://review.openstack.org/422658
Committed: https://git.openstack.org/cgit/openstack/tripleo-common/commit/?id=746b24692d754e0d42d602f9391888ed22e7d0bc
Submitter: Jenkins
Branch: master

commit 746b24692d754e0d42d602f9391888ed22e7d0bc
Author: Brad P. Crochet <email address hidden>
Date: Thu Jan 19 09:44:15 2017 -0500

    Add a delete stack workflow

    Create a workflow that will delete a stack.

    Change-Id: Ideeb8b443c862851cd54624a33222d76e14e5751
    Partial-Bug: #1657461

Reviewed: https://review.openstack.org/422806
Committed: https://git.openstack.org/cgit/openstack/python-tripleoclient/commit/?id=d6a2db92fcedbf759de51f07d23e3fa1401533f1
Submitter: Jenkins
Branch: master

commit d6a2db92fcedbf759de51f07d23e3fa1401533f1
Author: Brad P. Crochet <email address hidden>
Date: Thu Jan 19 13:37:30 2017 -0500

    Migrate overcloud delete to full workflow

    Previously, the overcloud delete only used a workflow to delete the plan.
    This uses a workflow for stack deletion too.

    Change-Id: I954416ddcef78625244018e1d885b396164e87fb
    Closes-Bug: #1657461
    Depends-On: Ideeb8b443c862851cd54624a33222d76e14e5751

Changed in tripleo:
status: In Progress → Fix Released

This issue was fixed in the openstack/python-tripleoclient 6.0.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers