Mitaka ha ping test failing to ping vm

Bug #1654615 reported by Ben Nemec on 2017-01-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Critical
Ben Nemec

Bug Description

This appears to be a different bug from the one breaking the nonha job. This one successfully uploads the image and boots the vm but fails to ping it. Looking through the logs I don't see anything obviously wrong, but I do notice that when we try to show the console log of the booted vm we get no output. I don't see any errors that would suggest it didn't boot correctly, so I'm not sure what's going on there.

Tags: ci Edit Tag help
tags: added: ci
Ben Nemec (bnemec) wrote :

Reproduced this behavior locally and it looks like the vm is hanging at an ipxe boot screen.

Ben Nemec (bnemec) wrote :

It appears to have something to do with the newer seabios-bin package that came in since this job was working. The current failing version is seabios-bin-1.9.1-5.el7.noarch. If I download the older seabios-1.7.5-11.el7.x86_64.rpm from http://buildlogs.centos.org/centos/7/virt/x86_64/kvm-common/ then booting the vm works as expected and it pings correctly. This is also the version of seabios-bin that was in the last passing mitaka job I can find.

I also tried going back to 1.9.1 to verify it wasn't the vm reboot alone that fixed the problem. It hung again on the newer package.

Alan Pevec (apevec) wrote :

seabios-bin-1.9.1-5.el7 is CentOS 7.3 base, so this needs to be raised as RHEL bz

Ben Nemec (bnemec) wrote :

I believe using the rdo-qemu-ev repo in the mitaka jobs will work around this problem. I'm not sure whether we should be using that repo with that release, but it's working for me locally. I pushed https://review.openstack.org/#/c/418510/ to test it.

I will also followup on the fact that using the qemu in base centos doesn't seem to be working.

Ben Nemec (bnemec) wrote :
Changed in tripleo:
assignee: nobody → Ben Nemec (bnemec)
Ben Nemec (bnemec) wrote :

A workaround for this is in the gate, so I'm going to drop the alert tag so it stops spamming the channel.

tags: removed: alert
Ben Nemec (bnemec) wrote :

This appears to have been fixed. https://review.openstack.org/#/c/425753/ will remove the workaround.

Changed in tripleo:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.