Multinode job broken: fails to build image

Bug #1647763 reported by Thomas Herve on 2016-12-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Critical
Thomas Herve

Bug Description

Seen in a couple of multinode jobs today as http://logs.openstack.org/03/407203/5/check/gate-tripleo-ci-centos-7-nonha-multinode/87b6333/console.html

2016-12-06 14:37:19.090523 | ++ tripleo-build-images --image-json-output --image-name overcloud-full --image-config-file /usr/share/tripleo-common/image-yaml/overcloud-images-centos7.yaml --image-config-file /usr/share/tripleo-common/image-yaml/overcloud-images.yaml
2016-12-06 14:37:19.090543 | ++ jq '. | .[0].packages | .[] | tostring'
2016-12-06 14:37:19.090555 | ++ sed 's/"//g'
2016-12-06 14:37:19.090578 | parse error: Invalid numeric literal at line 1, column 11
2016-12-06 14:37:19.090595 | Traceback (most recent call last):
2016-12-06 14:37:19.090621 | File "/usr/lib64/python2.7/logging/__init__.py", line 875, in emit
2016-12-06 14:37:19.090633 | self.flush()
2016-12-06 14:37:19.090660 | File "/usr/lib64/python2.7/logging/__init__.py", line 835, in flush
2016-12-06 14:37:19.090674 | self.stream.flush()
2016-12-06 14:37:19.090702 | IOError: [Errno 32] Broken pipe
2016-12-06 14:37:19.090733 | Logged from file base.py, line 88

It seems like there was a change in oslo.log triggering it.

Fix proposed to branch: master
Review: https://review.openstack.org/407565

Changed in tripleo:
assignee: nobody → Thomas Herve (therve)
status: New → In Progress
Changed in tripleo:
importance: Undecided → Critical
tags: added: alert ci
Changed in tripleo:
milestone: none → ocata-2

Reviewed: https://review.openstack.org/407565
Committed: https://git.openstack.org/cgit/openstack/tripleo-common/commit/?id=41c42cb4a9dcdb9eeeb9278db2500889c2b05044
Submitter: Jenkins
Branch: master

commit 41c42cb4a9dcdb9eeeb9278db2500889c2b05044
Author: Thomas Herve <email address hidden>
Date: Tue Dec 6 16:22:01 2016 +0100

    Fix build-image script output

    oslo.log changed the default for stderr, and it broke output parsing
    that we do.

    Change-Id: I14a7705e7c10d5f1fe44544e2764fbb0fa05e7d9
    Closes-Bug: #1647763

Changed in tripleo:
status: In Progress → Fix Released
Alex Schultz (alex-schultz) wrote :

Looks like maybe the tripleo package pins just fixed it. Setting back to Fix Released unless it shows up again.

Changed in tripleo:
status: Confirmed → Fix Released
tags: removed: alert

This issue was fixed in the openstack/tripleo-common 5.7.0 release.

Reviewed: https://review.openstack.org/417483
Committed: https://git.openstack.org/cgit/openstack/tripleo-common/commit/?id=b83a0935bc063e8fe48b56ffb88e5d86ba4e93af
Submitter: Jenkins
Branch: stable/newton

commit b83a0935bc063e8fe48b56ffb88e5d86ba4e93af
Author: Thomas Herve <email address hidden>
Date: Tue Dec 6 16:22:01 2016 +0100

    Fix build-image script output

    oslo.log changed the default for stderr, and it broke output parsing
    that we do.

    Change-Id: I14a7705e7c10d5f1fe44544e2764fbb0fa05e7d9
    Closes-Bug: #1647763
    (cherry picked from commit 41c42cb4a9dcdb9eeeb9278db2500889c2b05044)

tags: added: in-stable-newton

This issue was fixed in the openstack/tripleo-common 5.4.2 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers