stable/newton minor update: os-net-config package update restarts the network when corosync is already up and running

Bug #1644138 reported by Marios Andreou on 2016-11-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Critical
Brent Eagles

Bug Description

As first discussed at https://bugzilla.redhat.com/show_bug.cgi?id=1396904 we should run os-net-config before the cluster is brought back up as part of the minor update

fixup proposed by beagles @ "Run os-net-config before restarting cluster on update " https://review.openstack.org/#/c/400960/2 I65fb104465ff3d37ddc791634302994334136014 tripleo-heat-templates

Changed in tripleo:
assignee: Brent Eagles (beagles) → Marios Andreou (marios-b)
Changed in tripleo:
assignee: Marios Andreou (marios-b) → Brent Eagles (beagles)

Reviewed: https://review.openstack.org/400960
Committed: https://git.openstack.org/cgit/openstack/tripleo-heat-templates/commit/?id=476b05442817263d90e8c54a9b79cd0a8625862c
Submitter: Jenkins
Branch: master

commit 476b05442817263d90e8c54a9b79cd0a8625862c
Author: Brent Eagles <email address hidden>
Date: Tue Nov 22 17:18:45 2016 -0330

    Run os-net-config before restarting cluster on update

    Running os-net-config before restarting the cluster prevents changes to
    the interface files caused by changes to implementation from bouncing
    network interfaces after the cluster has restarted.

    Closes-Bug: #1644138

    Change-Id: I65fb104465ff3d37ddc791634302994334136014

Changed in tripleo:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/401987
Committed: https://git.openstack.org/cgit/openstack/tripleo-heat-templates/commit/?id=d2c439298dc03a7b9e4fd7080f2dd5f0d6a2ab6a
Submitter: Jenkins
Branch: stable/newton

commit d2c439298dc03a7b9e4fd7080f2dd5f0d6a2ab6a
Author: Brent Eagles <email address hidden>
Date: Tue Nov 22 17:18:45 2016 -0330

    Run os-net-config before restarting cluster on update

    Running os-net-config before restarting the cluster prevents changes to
    the interface files caused by changes to implementation from bouncing
    network interfaces after the cluster has restarted.

    Closes-Bug: #1644138

    Change-Id: I65fb104465ff3d37ddc791634302994334136014
    (cherry picked from commit 476b05442817263d90e8c54a9b79cd0a8625862c )

tags: added: in-stable-newton

This issue was fixed in the openstack/tripleo-heat-templates 6.0.0.0b2 development milestone.

This issue was fixed in the openstack/tripleo-heat-templates 5.2.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers