CI: apache fails to start on overcloud controller

Bug #1640879 reported by Sagi (Sergey) Shnaidman on 2016-11-10
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
tripleo
Critical
Emilien Macchi

Bug Description

Apache fails to start on overcloud.

[1;31mError: /Stage[main]/Apache::Service/Service[httpd]: Failed to call refresh: Could not restart Service[httpd]: Execution of '/usr/bin/systemctl restart httpd' returned 1: Job for httpd.service failed because a timeout was exceeded. See "systemctl status httpd.service" and "journalctl -xe" for details.
2016-11-10 16:37:04.000 | Error: /Stage[main]/Apache::Service/Service[httpd]: Could not restart Service[httpd]: Execution of '/usr/bin/systemctl restart httpd' returned 1: Job for httpd.service failed because a timeout was exceeded. See "systemctl status httpd.service" and "journalctl -xe" for details.

http://logs.openstack.org/48/375348/6/check-tripleo/gate-tripleo-ci-centos-7-ovb-ha/f6a3a55/logs/postci.txt.gz#_2016-11-09_12_46_48_000

http://logs.openstack.org/21/395521/1/check-tripleo/gate-tripleo-ci-centos-7-ovb-ha/715a49d/logs/postci.txt.gz#_2016-11-09_13_02_36_000

http://logs.openstack.org/02/395702/4/check-tripleo/gate-tripleo-ci-centos-7-ovb-ha/70abfa6/logs/postci.txt.gz#_2016-11-10_16_37_04_000

See also may be related: https://bugs.launchpad.net/tripleo/+bug/1572976

Tags: ci Edit Tag help
Changed in tripleo:
status: New → Invalid
description: updated
Changed in tripleo:
status: Invalid → Confirmed
status: Confirmed → Triaged
importance: Undecided → High

When tried to run it with quickstart it appears that httpd has "*:8774" in its virtualhost configuration, but nova-api listens on non-vip 8774 port and haproxy on vip 8774 port. So when httpd tries to start it fails with "can not bind socket" error.
But it may be a root cause only for this job.

Changed in tripleo:
milestone: none → ocata-2
importance: High → Critical
tags: added: alert
Changed in tripleo:
assignee: nobody → Emilien Macchi (emilienm)
Emilien Macchi (emilienm) wrote :

We promoted CI and have new robotop and horizon. It works now: https://review.openstack.org/#/c/400944/

Changed in tripleo:
status: Triaged → Fix Released
tags: removed: alert
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers