python-triploeclient disregards some parameters in environment files

Bug #1632683 reported by Attila Fazekas on 2016-10-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Critical
Jiří Stránský

Bug Description

The CephClusterFSID and CephClientKey is ignored from my altered https://github.com/openstack/tripleo-heat-templates/blob/master/environments/puppet-ceph-external.yaml file.

The client generates a random CephClusterFSID, CephClientKey.

The /etc/ceph/* on the deployed nodes has a not working values,
the other values like GlanceRbdPoolName was respected from the same environment file.

description: updated
Giulio Fidente (gfidente) wrote :

Can you pleae check if the Ceph key deployed on the nodes matches that saved on the undercloud in tripleo-overcloud-passwords file?

Changed in tripleo:
importance: Undecided → Critical
status: New → Confirmed
tags: added: newton-backport-potential
summary: - python-triploeclient dissregards ceph keys from envronemnt file
+ python-triploeclient dissregards ceph keys from an environment file
Changed in tripleo:
milestone: none → newton-rc3
Emilien Macchi (emilienm) wrote :

Moving to ocata-1, since no assignee, and we're releasing RC this week.

Changed in tripleo:
milestone: newton-rc3 → ocata-1
Giulio Fidente (gfidente) wrote :

Wonder if we shouldn't mark this as clone/duplicate of bug 1632013 ?

This affects also NeutronDhcpAgentsPerNetwork parameter. The problem is that we started prioritizing the CLI defaults over the environment files. We've already solved this problem before, it's a regression. Unfortunately i cannot seem to dig up the previous relevant LP bug.

summary: - python-triploeclient dissregards ceph keys from an environment file
+ python-triploeclient dissregards some parameters in environment files
Changed in tripleo:
assignee: nobody → Jiří Stránský (jistr)
summary: - python-triploeclient dissregards some parameters in environment files
+ python-triploeclient disregards some parameters in environment files

Fix proposed to branch: master
Review: https://review.openstack.org/386669

Changed in tripleo:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/386669
Committed: https://git.openstack.org/cgit/openstack/python-tripleoclient/commit/?id=71ebf2a31ecaee96342599c2d14ee5325d6d6413
Submitter: Jenkins
Branch: master

commit 71ebf2a31ecaee96342599c2d14ee5325d6d6413
Author: Jiri Stransky <email address hidden>
Date: Fri Oct 14 17:15:33 2016 +0200

    Allow overriding CLI parameter defaults with env files

    We've added the ability to override CLI defaults with environment files
    [1] but then it got reversed while fixing a related bug [2]. We need to
    put this ability back because otherwise we cannot customize
    e.g. NeutronDhcpAgentsPerNetwork, or deploy with external Ceph with
    custom FSID and key.

    As a related change we have to remove hardcoded role counts from
    overcloud-env.json, because they'd overwrite the counts passed via
    CLI. (Furthermore, having the hardcoded default counts there doesn't
    make too much sense now that we have custom roles, the counts should
    already be properly defaulted in role_data.yaml.)

    [1] Change ID I2722e118abde1cea6210148b16ac1ed3d9f235d8
    [2] Change ID I80c663c23dfa27fa7b4ca2bf6b0101c132e5889b

    Closes-Bug: #1632683
    Change-Id: Iaf0adda44c84fcc552e743e4712d1dcf01daa7e4

Changed in tripleo:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/387919
Committed: https://git.openstack.org/cgit/openstack/python-tripleoclient/commit/?id=0b2984f687c4377b7367cfaf7f72a25a9bfbb6bd
Submitter: Jenkins
Branch: stable/newton

commit 0b2984f687c4377b7367cfaf7f72a25a9bfbb6bd
Author: Jiri Stransky <email address hidden>
Date: Fri Oct 14 17:15:33 2016 +0200

    Allow overriding CLI parameter defaults with env files

    We've added the ability to override CLI defaults with environment files
    [1] but then it got reversed while fixing a related bug [2]. We need to
    put this ability back because otherwise we cannot customize
    e.g. NeutronDhcpAgentsPerNetwork, or deploy with external Ceph with
    custom FSID and key.

    As a related change we have to remove hardcoded role counts from
    overcloud-env.json, because they'd overwrite the counts passed via
    CLI. (Furthermore, having the hardcoded default counts there doesn't
    make too much sense now that we have custom roles, the counts should
    already be properly defaulted in role_data.yaml.)

    [1] Change ID I2722e118abde1cea6210148b16ac1ed3d9f235d8
    [2] Change ID I80c663c23dfa27fa7b4ca2bf6b0101c132e5889b

    Closes-Bug: #1632683
    Change-Id: Iaf0adda44c84fcc552e743e4712d1dcf01daa7e4
    (cherry picked from commit 71ebf2a31ecaee96342599c2d14ee5325d6d6413)

tags: added: in-stable-newton

This issue was fixed in the openstack/python-tripleoclient 5.4.0 release.

This issue was fixed in the openstack/python-tripleoclient 5.5.0 release.

This issue was fixed in the openstack/python-tripleoclient 5.4.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers