deploying an overcloud a second time after a failure, doesn't find overcloud.yaml

Bug #1622720 reported by Ryan Hallisey on 2016-09-12
This bug report is a duplicate of:  Bug #1622683: Updating plans breaks deployment. Edit Remove
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
tripleo
Undecided
Dougal Matthews

Bug Description

[stack@instack ~]$ openstack overcloud deploy --templates -e /usr/share/openstack-tripleo-heat-templates/overcloud-resource-registry-puppet.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/puppet
-pacemaker.yaml --control-scale 3 --compute-scale 1 --libvirt-type qemu --ntp-server '0.fedora.pool.ntp.org'
WARNING: openstackclient.common.utils is deprecated and will be removed after Jun 2017. Please use osc_lib.utils
WARNING: openstackclient.common.exceptions is deprecated and will be removed after Jun 2017. Please use osc_lib.exceptions
Removing the current plan files
Uploading new plan files
Plan updated
Deploying templates in the directory /usr/share/openstack-tripleo-heat-templates
Object GET failed: http://192.0.2.1:8080/v1/AUTH_42e81ee8038247148a32eab70700ce21/overcloud/overcloud-without-mergepy.yaml 404 Not Found [first 60 chars of response] <html><h1>Not Found</h1><p>The resource cou$
d not be found.<
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/swiftclient/client.py", line 1565, in _retry
    service_token=self.service_token, **kwargs)
  File "/usr/lib/python2.7/site-packages/swiftclient/client.py", line 1116, in get_object
    http_response_content=body)
ClientException: Object GET failed: http://192.0.2.1:8080/v1/AUTH_42e81ee8038247148a32eab70700ce21/overcloud/overcloud-without-mergepy.yaml 404 Not Found [first 60 chars of response] <html><h1>Not Found</h1><p$
The resource could not be found.<
Object GET failed: http://192.0.2.1:8080/v1/AUTH_42e81ee8038247148a32eab70700ce21/overcloud/overcloud.yaml 404 Not Found [first 60 chars of response] <html><h1>Not Found</h1><p>The resource could not be found.$
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/swiftclient/client.py", line 1565, in _retry
    service_token=self.service_token, **kwargs)
  File "/usr/lib/python2.7/site-packages/swiftclient/client.py", line 1116, in get_object
    http_response_content=body)
ClientException: Object GET failed: http://192.0.2.1:8080/v1/AUTH_42e81ee8038247148a32eab70700ce21/overcloud/overcloud.yaml 404 Not Found [first 60 chars of response] <html><h1>Not Found</h1><p>The resource co$
ld not be found.<
The following errors occurred:
Object GET failed: http://192.0.2.1:8080/v1/AUTH_42e81ee8038247148a32eab70700ce21/overcloud/overcloud-without-mergepy.yaml 404 Not Found [first 60 chars of response] <html><h1>Not Found</h1><p>The resource cou$
d not be found.<
Object GET failed: http://192.0.2.1:8080/v1/AUTH_42e81ee8038247148a32eab70700ce21/overcloud/overcloud.yaml 404 Not Found [first 60 chars of response] <html><h1>Not Found</h1><p>The resource could not be found.$

Ryan Hallisey (rthall14) wrote :

Sometimes a deploy fails with a 500 error from nova. After you delete the stack in heat, when you go to redeploy you get this error returned from swift.

Workaround:
mistral environment-delete overcloud
swift delete --all

Julie Pichon (jpichon) wrote :

Thank you for the bug report! I think this may be a duplicate of bug 1622683, looking at the output a failing job mentioned in the description:

http://logs.openstack.org/60/368760/2/check-tripleo/gate-tripleo-ci-centos-7-ovb-ha/2753a43/console.html#_2016-09-12_18_34_44_378180

Changed in tripleo:
assignee: nobody → Dougal Matthews (d0ugal)
status: New → In Progress

Reviewed: https://review.openstack.org/368760
Committed: https://git.openstack.org/cgit/openstack/tripleo-common/commit/?id=af27127508eabf2b6873713e5e1507fa92b5f5b3
Submitter: Jenkins
Branch: master

commit af27127508eabf2b6873713e5e1507fa92b5f5b3
Author: Dougal Matthews <email address hidden>
Date: Mon Sep 12 11:24:30 2016 +0000

    Add template processing to the update plan workflow.

    This was recently added to the create workflow, but as update
    was added at the same time it wasn't included.

    Partial-Bug: #1622683
    Closes-Bug: #1622720

    Change-Id: Ia014d85d7e601d436ae9267df5988f4a6e962574

Changed in tripleo:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/371027
Committed: https://git.openstack.org/cgit/openstack/tripleo-common/commit/?id=2d87e9640427f12eb5604f290fe38eae00f402ee
Submitter: Jenkins
Branch: master

commit 2d87e9640427f12eb5604f290fe38eae00f402ee
Author: Dougal Matthews <email address hidden>
Date: Fri Sep 16 09:15:43 2016 +0100

    Add template processing to the update plan workflow.

    This was recently added to the create workflow, but as update
    was added at the same time it wasn't included.

    Partial-Bug: #1622683
    Closes-Bug: #1622720
    Change-Id: I96ff13a00ac98bdfeb6605e9d300f8a44e6f82f1

This issue was fixed in the openstack/tripleo-common 5.2.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers