CI broken: RDO picks stable/newton tripleoclient version in master

Bug #1622353 reported by Emilien Macchi on 2016-09-11
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
tripleo
Critical
Emilien Macchi

Bug Description

We merged this patch: https://review.openstack.org/#/c/315679/
But it seems like now CI is failing to find overcloud YAMLs:

6:19:49.979948 | Deploying templates in the directory /usr/share/openstack-tripleo-heat-templates
2016-09-11 16:19:53.927301 | The following errors occurred:
2016-09-11 16:19:53.927537 | [Errno 2] No such file or directory: '/usr/share/openstack-tripleo-heat-templates/overcloud-without-mergepy.yaml'
2016-09-11 16:19:53.927609 | [Errno 2] No such file or directory: '/usr/share/openstack-tripleo-heat-templates/overcloud.yaml'

http://logs.openstack.org/18/347918/5/check/gate-tripleo-ci-centos-7-nonha-multinode/e7c4b3b/console.html#_2016-09-11_16_19_53_927609

Tags: ci Edit Tag help
Emilien Macchi (emilienm) wrote :
Changed in tripleo:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Emilien Macchi (emilienm)
tags: added: alert ci
Emilien Macchi (emilienm) wrote :

As a side node, something broke super recently, this is the latest successful CI job: https://review.openstack.org/#/c/290571/

Emilien Macchi (emilienm) wrote :

so I compared packaging between latest working job and latest failing job and here's the only 2 diffs:

Broken:
python-tripleoclient-5.0.0-0.20160907170033.b0d7ce7.el7.centos.noarch
openstack-tripleo-heat-templates-5.0.0-0.20160911020155.2eb0f7c.el7.centos.noarch

Working:
python-tripleoclient-5.0.1-0.20160911093359.7923128.el7.centos.noarch
openstack-tripleo-heat-templates-5.0.0-0.20160910143051.44056af.el7.centos.noarch

So the question is why do we have python-tripleoclient downgrade in recent jobs?
Because of that, I think we're missing this patch:
https://github.com/openstack/python-tripleoclient/commit/2898e7595f5df5ad9e46a137a8fd5ca6bf166369
And our CI is failing to find the templates.

Emilien Macchi (emilienm) wrote :

tripleoclient was branched to stable/newton and RDO now picks it by default, and don't follow master anymore. That is the root cause.

summary: - CI broken: overcloud.yaml not found
+ CI broken: RDO picks stable/newton tripleoclient version in master
Emilien Macchi (emilienm) wrote :

Should be temporary fixed by https://review.rdoproject.org/r/#/c/2186/ - For the future, we need to backport patches from master to stable/newton.

Changed in tripleo:
status: Confirmed → In Progress
tags: removed: alert
Steven Hardy (shardy) wrote :

Thanks for the debugging Emilien - I saw similar issues earlier and suspected we were using an old tripleoclient, but didn't fully diagnose the root cause.

Can we enumerate the patches we need to backport here (is it just my one enabling j2 templating?), propose them to stable/newton then declare this complete?

Alan Pevec (apevec) wrote :

So why was tripleoclient stable/newton created if it was not ready? It has release:cycle-trailing so it should not be handled like other clients?

Alan Pevec (apevec) wrote :

> Working:
> python-tripleoclient-5.0.1-0.20160911093359.7923128.el7.centos.noarch

Where did you get this one from?

Changed in tripleo:
status: In Progress → Fix Released
milestone: none → newton-rc1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers