Add feedback during plan deletion

Bug #1614939 reported by Dougal Matthews on 2016-08-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Medium
Ryan Brady

Bug Description

This was reported as a blueprint, but I believe it is a bug: https://blueprints.launchpad.net/tripleo/+spec/improve-plan-deletion

When a plan is deleted no feedback is provided in the case of a failure. We should change that.

Original blueprint text:

 > We probably want to improve the feedback to the user in the future, for
 > example if the container name doesn't exist (e.g. typo) we don't tell the user
 > anything right now. Containers that aren't actually plans also get deleted,
 > but that's probably not that important in this context.

Julie Pichon (jpichon) wrote :

Since this is taken from a comment I left on a review, I'd like to add a little bit to it: I was thinking since it's the undercloud there shouldn't be data in Swift that's not related to deployments, but if it is simple enough to check whether a container is a plan or not before deleting it, that would be preferable.

Ryan Brady (rbrady) on 2016-09-19
Changed in tripleo:
assignee: nobody → Ryan Brady (rbrady)
Ryan Brady (rbrady) on 2016-12-07
Changed in tripleo:
status: Confirmed → In Progress
milestone: none → ocata-2
Changed in tripleo:
milestone: ocata-2 → ocata-3
Ryan Brady (rbrady) wrote :
Changed in tripleo:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers