tripleo.sh --repo-setup fails when fetching delorean.repo

Bug #1595448 reported by Carlos Camacho on 2016-06-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Undecided
Carlos Camacho

Bug Description

The URL http://trunk.rdoproject.org/centos7/current-tripleo//delorean.repo
Was moved to http://buildlogs.centos.org/centos/7/cloud/x86_64/rdo-trunk-master-tripleo//delorean.repo

Making tripleo.sh --repo-setup fail.

How to reproduce:
[stack@dell-per610-01 ~]$ /home/stack/tripleo-ci/scripts/tripleo.sh --repo-setup
#################
tripleo.sh -- Repository setup
#################
epel-release-7-7.noarch
  % Total % Received % Xferd Average Speed Time Time Time Current
                                 Dload Upload Total Spent Left Speed
100 162 100 162 0 0 434 0 --:--:-- --:--:-- --:--:-- 435
  % Total % Received % Xferd Average Speed Time Time Time Current
                                 Dload Upload Total Spent Left Speed
100 258 100 258 0 0 1042 0 --:--:-- --:--:-- --:--:-- 1044
  % Total % Received % Xferd Average Speed Time Time Time Current
                                 Dload Upload Total Spent Left Speed
100 218 100 218 0 0 875 0 --:--:-- --:--:-- --:--:-- 875
Loaded plugins: fastestmirror, priorities

File contains no section headers.
file: file:///etc/yum.repos.d/delorean.repo, line: 1
'<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">\n'

Changed in tripleo:
assignee: nobody → Carlos Camacho (ccamacho)
Carlos Camacho (ccamacho) wrote :
Changed in tripleo:
status: New → Fix Committed
Carlos Camacho (ccamacho) wrote :

After updating the URL:

[stack@dell-per610-01 ~]$ /home/stack/tripleo-ci/scripts/tripleo.sh --repo-setup
#################
tripleo.sh -- Repository setup
#################
epel-release-7-7.noarch
Dentro de no stable release
sudo curl -o /etc/yum.repos.d//delorean-deps.repo http://trunk.rdoproject.org/centos7/delorean-deps.repo
  % Total % Received % Xferd Average Speed Time Time Time Current
                                 Dload Upload Total Spent Left Speed
100 162 100 162 0 0 215 0 --:--:-- --:--:-- --:--:-- 215
sudo sed -i -e 's%priority=.*%priority=30%' /etc/yum.repos.d//delorean-deps.repo
sudo curl -o /etc/yum.repos.d//delorean.repo http://buildlogs.centos.org/centos/7/cloud/x86_64/rdo-trunk-master-tripleo//delorean.repo
  % Total % Received % Xferd Average Speed Time Time Time Current
                                 Dload Upload Total Spent Left Speed
100 214 100 214 0 0 506 0 --:--:-- --:--:-- --:--:-- 507
sudo sed -i -e 's%priority=.*%priority=20%' /etc/yum.repos.d//delorean.repo
  % Total % Received % Xferd Average Speed Time Time Time Current
                                 Dload Upload Total Spent Left Speed
100 212 100 212 0 0 863 0 --:--:-- --:--:-- --:--:-- 865
Loaded plugins: fastestmirror, priorities
delorean | 2.9 kB 00:00:00
Not using downloaded repomd.xml because it is older than what we have:
  Current : Wed Jun 22 10:13:04 2016
  Downloaded: Thu Jun 2 21:41:30 2016
delorean-current | 3.0 kB 00:00:00
delorean-newton-testing | 2.9 kB 00:00:00
delorean-current/primary_db | 235 kB 00:00:00
Loading mirror speeds from cached hostfile
 * base: mirror.karneval.cz
 * epel: download.eng.brq.redhat.com
 * extras: mirror.karneval.cz
 * updates: mirror.karneval.cz
593 packages excluded due to repository priority protections
Package yum-plugin-priorities-1.1.31-34.el7.noarch already installed and latest version
Nothing to do
#################
tripleo.sh -- Repository setup - DONE.
#################

Derek Higgins (derekh) on 2016-06-27
Changed in tripleo:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers