python-tripleoclient doesnt show actual path to missing templates

Bug #1584792 reported by James Slagle on 2016-05-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
High
James Slagle

Bug Description

If you specify an incorrect path to a template or environment file, or the path is correct, but the file does not exist, python-tripleoclient just prints a generic error message because it assumes that overcloud.yaml is the missing file from the template root directory.

In cases where overcloud.yaml actually does exist and the error was caused by a different missing template or environment file, the error message is confusing.

James Slagle (james-slagle) wrote :
Changed in tripleo:
status: New → In Progress
importance: Undecided → High
assignee: nobody → James Slagle (james-slagle)
milestone: none → newton-1

Reviewed: https://review.openstack.org/300462
Committed: https://git.openstack.org/cgit/openstack/python-tripleoclient/commit/?id=7a05679ebc944e3bec6f20c194c40fae1cf39d8d
Submitter: Jenkins
Branch: master

commit 7a05679ebc944e3bec6f20c194c40fae1cf39d8d
Author: James Slagle <email address hidden>
Date: Fri Apr 1 08:57:41 2016 -0400

    Show correct missing files when an error occurs

    This function was swallowing all missing file exceptions, and then
    printing a message saying overcloud.yaml or
    overcloud-without-mergepy.yaml were not found.

    The problem is that the URLError could occur for any missing file, such
    as a missing environment file, typo in a relative patch or filename,
    etc. And in those cases, the error message is actually quite misleading,
    especially if the overcloud.yaml does exist at the exact shown path.

    This change makes it such that the actual missing file paths are shown
    in the output.

    Closes-Bug: 1584792
    Change-Id: Id9a70cb50d7dfa3dde72eefe0a5eaea7985236ff

Changed in tripleo:
status: In Progress → Fix Released

This issue was fixed in the openstack/python-tripleoclient 5.0.0.0b1 development milestone.

tags: added: mitaka-backport-potential

Reviewed: https://review.openstack.org/329438
Committed: https://git.openstack.org/cgit/openstack/python-tripleoclient/commit/?id=55ccfeac34556bfba697cb4190cc29b9f1c771d1
Submitter: Jenkins
Branch: stable/mitaka

commit 55ccfeac34556bfba697cb4190cc29b9f1c771d1
Author: James Slagle <email address hidden>
Date: Fri Apr 1 08:57:41 2016 -0400

    Show correct missing files when an error occurs

    This function was swallowing all missing file exceptions, and then
    printing a message saying overcloud.yaml or
    overcloud-without-mergepy.yaml were not found.

    The problem is that the URLError could occur for any missing file, such
    as a missing environment file, typo in a relative patch or filename,
    etc. And in those cases, the error message is actually quite misleading,
    especially if the overcloud.yaml does exist at the exact shown path.

    This change makes it such that the actual missing file paths are shown
    in the output.

    Closes-Bug: 1584792
    Change-Id: Id9a70cb50d7dfa3dde72eefe0a5eaea7985236ff
    (cherry picked from commit 7a05679ebc944e3bec6f20c194c40fae1cf39d8d)

tags: added: in-stable-mitaka

This issue was fixed in the openstack/python-tripleoclient 2.1.0 release.

This issue was fixed in the openstack/python-tripleoclient 2.1.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers