mariadb fails to start with port in use error

Bug #1442256 reported by Steven Hardy on 2015-04-09
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
tripleo
Critical
Dan Prince

Bug Description

I'm seeing mariadb consistently fail to start on the controller, error and my devtest rc (running on F20 host) attached.

[shardy@localhost tripleo]$ heat resource-list overcloud | grep FAILED
| ControllerNodesPostDeployment | 9db2256b-852c-40a2-997e-554c25e0edae | OS::TripleO::ControllerPostDeployment | CREATE_FAILED | 2015-04-09T15:50:44Z |
[shardy@localhost tripleo]$ heat resource-show overcloud ControllerNodesPostDeployment | grep physical_resource_id
| physical_resource_id | 9db2256b-852c-40a2-997e-554c25e0edae |
[shardy@localhost tripleo]$ heat resource-list 9db2256b-852c-40a2-997e-554c25e0edae | grep FAILED
| ControllerDeploymentServicesBase_Step2 | a7a461bd-97e0-4f83-821f-941af88ef24f | OS::Heat::StructuredDeployments | CREATE_FAILED | 2015-04-09T15:54:09Z |
[shardy@localhost tripleo]$ heat resource-show 9db2256b-852c-40a2-997e-554c25e0edae ControllerDeploymentServicesBase_Step2
+------------------------+-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+
| Property | Value |
+------------------------+-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+
| attributes | { |
| | "deploy_stderrs": null, |
| | "deploy_stdouts": null, |
| | "deploy_status_codes": null |
| | } |
| description | |
| links | http://192.0.2.1:8004/v1/4979d9b259b641e3a44994d348a826a1/stacks/overcloud-ControllerNodesPostDeployment-cczboahhomip/9db2256b-852c-40a2-997e-554c25e0edae/resources/ControllerDeploymentServicesBase_Step2 (self) |
| | http://192.0.2.1:8004/v1/4979d9b259b641e3a44994d348a826a1/stacks/overcloud-ControllerNodesPostDeployment-cczboahhomip/9db2256b-852c-40a2-997e-554c25e0edae (stack) |
| | http://192.0.2.1:8004/v1/4979d9b259b641e3a44994d348a826a1/stacks/overcloud-ControllerNodesPostDeployment-cczboahhomip-ControllerDeploymentServicesBase_Step2-pmsx4bbn23h7/a7a461bd-97e0-4f83-821f-941af88ef24f (nested) |
| logical_resource_id | ControllerDeploymentServicesBase_Step2 |
| physical_resource_id | a7a461bd-97e0-4f83-821f-941af88ef24f |
| required_by | ControllerRingbuilderDeployment_Step3 |
| resource_name | ControllerDeploymentServicesBase_Step2 |
| resource_status | CREATE_FAILED |
| resource_status_reason | ResourceUnknownStatus: Resource failed - Unknown status FAILED due to "Resource CREATE failed: Error: Deployment to server failed: deploy_status_code : Deployment exited with non-zero status code: 6" |
| resource_type | OS::Heat::StructuredDeployments |
| updated_time | 2015-04-09T15:54:09Z

Steven Hardy (shardy) wrote :
Steven Hardy (shardy) wrote :
Jiří Stránský (jistr) wrote :

I'm seeing the same thing, also consistently it seems.

Changed in tripleo:
status: New → Triaged
importance: Undecided → Critical

Fix proposed to branch: master
Review: https://review.openstack.org/172355

Changed in tripleo:
assignee: nobody → Jiří Stránský (jistr)
status: Triaged → In Progress

Change abandoned by Dan Prince (<email address hidden>) on branch: master
Review: https://review.openstack.org/172379

Changed in tripleo:
assignee: Jiří Stránský (jistr) → Dan Prince (dan-prince)

Reviewed: https://review.openstack.org/172355
Committed: https://git.openstack.org/cgit/openstack/tripleo-heat-templates/commit/?id=bafe58c42d2c0c58346fce929cf443c0436b6cd5
Submitter: Jenkins
Branch: master

commit bafe58c42d2c0c58346fce929cf443c0436b6cd5
Author: Jiri Stransky <email address hidden>
Date: Fri Apr 10 11:28:44 2015 +0200

    MariaDB bind on correct address

    Despite passing bind-address for MariaDB in overcloud_controller.pp
    correctly, it was always trying to bind on 0.0.0.0. The problem is
    caused by Galera's config file (we install Galera into the image even
    though we don't use it yet). Galera's default config file contains
    override of the bind-address value to 0.0.0.0, and the setting from
    galera.cnf took precendence over what was in server.cnf.

    The mariadb-galera-server package assumes that the main config happens
    in galera.cnf and it ships an almost empty server.cnf. We now have an
    EnableGalera param, when it's set to true the mysql module will manage
    galera.cnf instead of server.cnf, overriding the default values from
    galera.cnf and fixing the issue.

    Change-Id: I7c2fd41d41dcf5eb4ee8b1dbd74d60cc2cabeed9
    Closes-Bug: #1442256

Changed in tripleo:
status: In Progress → Fix Committed
Jay Dobies (jdob) on 2015-04-10
Changed in tripleo:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers