RabbitClientUseSSL type error in overcloud-without-mergepy.yaml

Bug #1402928 reported by Leslie Wang on 2014-12-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
High
Gregory Haynes

Bug Description

heat report error if using overcloud-without-mergepy.yaml template.

ERROR: Property error : 0: RabbitClientUseSSL Value must be a string

After initial investigation, RabbitClientUseSSL should use either boolean type or set default value to 'fault' which is a string

  RabbitClientUseSSL:
    default: false
    description: >
        Rabbit client subscriber parameter to specify
        an SSL connection to the RabbitMQ host.
    type: string

James Polley (tchaypo) wrote :

This seems to have been introduced in https://review.openstack.org/#/c/139649/3/overcloud-without-mergepy.yaml

I'm not sure what the error is here though. If I'm reading the error message correctly, the value "0" is being passed, which is not a string, and which is overriding the default "false". Am i reading the error message wrong?

Leslie Wang (wqyuwss) wrote :

In my case, if I modified "default: false" to "default: "false"". The problem disappear.

James Polley (tchaypo) wrote :

Oh - that sounds as though 'false' is being interpreted as a boolean

This sounds like it should be simple to patch. Do you plan to work on submitting a patch for this? If you need any help, I'm tchaypo in #tripleo, and I or someone else should be able to help you get this submitted.

Ben Nemec (bnemec) on 2015-01-02
Changed in tripleo:
status: New → Triaged
importance: Undecided → High
Changed in tripleo:
assignee: nobody → Gregory Haynes (greghaynes)
status: Triaged → In Progress
Steven Hardy (shardy) wrote :

I can't reproduce this on heat master:

-bash-4.2$ heat stack-create b1 -f booltest.yaml
+--------------------------------------+------------+--------------------+----------------------+
| id | stack_name | stack_status | creation_time |
+--------------------------------------+------------+--------------------+----------------------+
| e5da1544-cecc-4871-945b-0acf35f8beb9 | b1 | CREATE_IN_PROGRESS | 2015-01-29T10:37:06Z |
+--------------------------------------+------------+--------------------+----------------------+
-bash-4.2$ heat stack-list
+--------------------------------------+------------+-----------------+----------------------+
| id | stack_name | stack_status | creation_time |
+--------------------------------------+------------+-----------------+----------------------+
| e5da1544-cecc-4871-945b-0acf35f8beb9 | b1 | CREATE_COMPLETE | 2015-01-29T10:37:06Z |
+--------------------------------------+------------+-----------------+----------------------+
-bash-4.2$ cat booltest.yaml
heat_template_version: 2014-10-16

parameters:
  RabbitClientUseSSL:
    default: false
    description: >
        Rabbit client subscriber parameter to specify
        an SSL connection to the RabbitMQ host.
    type: string

resources:
  foo:
    type: OS::Heat::SoftwareConfig
    properties:
      group: ungrouped
      config:
        str_replace:
          template: |
            #!/bin/bash -v
            echo "the parameter is $aparameter"
          params:
            $aparameter: { get_param: RabbitClientUseSSL }

Steven Hardy (shardy) wrote :

I think the reporter of this bug is using an old version of heat, which doesn't contain this fix:

https://bugs.launchpad.net/heat/+bug/1367375

This is the patch which fixed it:

https://review.openstack.org/#/c/125356/

I guess we need to backport that to Juno (assuming that's what the reporter is using), I'll look into that.

Steven Hardy (shardy) wrote :
Steven Hardy (shardy) wrote :

Heat stable backport has now landed:

https://review.openstack.org/#/c/151180/

Change abandoned by greghaynes (<email address hidden>) on branch: master
Review: https://review.openstack.org/151038

Changed in tripleo:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers