br-ex doesn't activate when overcloud controller is rebooted

Bug #1396730 reported by Pedro Sousa on 2014-11-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
High
Unassigned

Bug Description

Hi,

when the overcloud node is rebooted br-ex never comes up, hence the openstack-services don't come up. I tried to do:

NM_CONTROLLED=no ( in all interfaces)

#systemctl disable NetworkManager
#systemctl stop NetworkManager
#chkconfig network on
#service network restart

Then the br-ex comes up but with a different ip from the original (it should get 192.0.2.65)

br-ex: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
        inet 192.0.2.64 netmask 255.255.255.255 broadcast 0.0.0.0
        inet6 fe80::d6ae:52ff:fea1:cd80 prefixlen 64 scopeid 0x20<link>
        ether d4:ae:52:a1:cd:80 txqueuelen 0 (Ethernet)
        RX packets 480 bytes 116642 (113.9 KiB)
        RX errors 0 dropped 0 overruns 0 frame 0
        TX packets 517 bytes 61485 (60.0 KiB)
        TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

[stack@tripleo01 ~]$ neutron port-list
+--------------------------------------+--------------------+-------------------+-----------------------------------------------------------------------------------+
| id | name | mac_address | fixed_ips |
+--------------------------------------+--------------------+-------------------+-----------------------------------------------------------------------------------+
| 59383963-7b1b-47a1-9f40-0b73bc09b0f5 | | fa:16:3e:87:df:2f | {"subnet_id": "4e7e82cc-9256-47de-b360-b371b22c0be1", "ip_address": "192.0.2.60"} |
| aa712c82-9a61-4b4b-969b-2192219a1970 | | 00:a0:d1:e3:dd:ec | {"subnet_id": "4e7e82cc-9256-47de-b360-b371b22c0be1", "ip_address": "192.0.2.66"} |
| e77ed4c6-56c5-4210-a8f2-d3d08d3da488 | | d4:ae:52:a1:cd:80 | {"subnet_id": "4e7e82cc-9256-47de-b360-b371b22c0be1", "ip_address": "192.0.2.65"} |
| f3cf0e07-15d4-4df1-8e1a-dd654529c67a | public_virtual_ip | fa:16:3e:73:3e:8e | {"subnet_id": "4e7e82cc-9256-47de-b360-b371b22c0be1", "ip_address": "192.0.2.63"} |
| f9cbd49e-3f29-4fc6-9f0e-a2cb5625d2b4 | control_virtual_ip | fa:16:3e:18:05:f2 | {"subnet_id": "4e7e82cc-9256-47de-b360-b371b22c0be1", "ip_address": "192.0.2.64"} |
+--------------------------------------+--------------------+-------------------+---------------------------------------------------------------------------------

Regards

James Polley (tchaypo) wrote :

Out of curiosity, have you tried running os-collect-config --force --one to see if it's able to get the bridge back up?

Pedro Sousa (pgsousa) wrote :

Hi,

no I didn't. I don't have my environment up right now to test it.

Clint Byrum (clint-fewbar) wrote :

Please include your overcloud-env.json (redact secrets if necessary) and the output of 'os-collect-config --force --one'. It will be fairly difficult to reproduce this situation otherwise. I have rebooted controllers quite a few times myself of late, and had no problem like this, but my configuration is likely somewhat different. Also please let us know exactly what OS you're using.. ideally what elements you built the controller image with.

Changed in tripleo:
status: New → Incomplete
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

[Expired for tripleo because there has been no activity for 60 days.]

Changed in tripleo:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers