nova.conf config options were removed

Bug #1390427 reported by Derek Higgins
This bug report is a duplicate of:  Bug #1390408: No warning when deprecated opt used. Edit Remove
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Won't Fix
Undecided
Unassigned
oslo.config
Confirmed
High
Unassigned
tripleo
Fix Released
Critical
Derek Higgins

Bug Description

As of 2014-11-06 15:00 approx All tripleo jobs are failing

a load of deprecated options have been removed from nova causing the failure

https://review.openstack.org/#/c/132900/
https://review.openstack.org/#/c/132887/
https://review.openstack.org/#/c/132885/
https://review.openstack.org/#/c/132901/

They were deprecated but it looks like no warning were being generated in the logs

Tags: ci
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix proposed to nova (master)

Related fix proposed to branch: master
Review: https://review.openstack.org/133212

Revision history for this message
OpenStack Infra (hudson-openstack) wrote :

Related fix proposed to branch: master
Review: https://review.openstack.org/133213

Revision history for this message
OpenStack Infra (hudson-openstack) wrote :

Related fix proposed to branch: master
Review: https://review.openstack.org/133214

Revision history for this message
OpenStack Infra (hudson-openstack) wrote :

Related fix proposed to branch: master
Review: https://review.openstack.org/133215

Revision history for this message
Joe Gordon (jogo) wrote :

Not sure why this is marked as a nova bug, you shouldn't be using deprecated config options.

Revision history for this message
Joe Gordon (jogo) wrote :

You can use the setting

# Enables or disables fatal status of deprecations. (boolean
# value)
#fatal_deprecations=false

to detect deprecation when they are made.

Changed in nova:
status: New → Won't Fix
Revision history for this message
Derek Higgins (derekh) wrote :

The reason for the nova bug and the proposed reverts is not because the config options should not have been removed, there was no warnings in the logs about them, which essentially means we didn't know not to use them a problem other deployments will have once this is released.

Revision history for this message
Ben Nemec (bnemec) wrote :

fatal_deprecations wouldn't catch this because that only marks deprecations that are logged. These were not (a bug in oslo.config: https://bugs.launchpad.net/oslo.config/+bug/1390408 ), which is why IMNSHO the change should be reverted. The deprecated opts are not hurting anything, and removing them like this has the potential to break deployers with no warning.

Revision history for this message
Daniel Berrange (berrange) wrote :

Nova has followed this process of marking the config options deprecated for one release cycle and then deleting them in the second release cycle, for many releases now.

If there are things we can do to make the list of deprecated options be more obvious/visible to end users/downstream apps in future releases, that's great to discuss, but I don't see any reason why we should stop following our existing process for removal of deprecated options.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to tripleo-image-elements (master)

Fix proposed to branch: master
Review: https://review.openstack.org/133427

Changed in tripleo:
assignee: nobody → Derek Higgins (derekh)
status: Triaged → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to tripleo-image-elements (master)

Reviewed: https://review.openstack.org/133427
Committed: https://git.openstack.org/cgit/openstack/tripleo-image-elements/commit/?id=8e5ae2618d5e206f4ab9d8262e6287bd278d85af
Submitter: Jenkins
Branch: master

commit 8e5ae2618d5e206f4ab9d8262e6287bd278d85af
Author: Derek Higgins <email address hidden>
Date: Mon Nov 10 10:31:52 2014 +0000

    Switch to current options in nova.conf

    Switch some nova.conf options to the most current name/group,
    the old names were deprecated in nova in Juno and have now
    been removed.
    Closes-Bug: #1390427

    Change-Id: I7eb06d70aba99592152559252fb2bf2058dc39c6

Changed in tripleo:
status: In Progress → Fix Committed
Derek Higgins (derekh)
Changed in tripleo:
status: Fix Committed → Fix Released
Changed in oslo.config:
importance: Undecided → High
status: New → Confirmed
Revision history for this message
Dan Prince (dan-prince) wrote :

I've always viewed fatal_deprecations as a test time flag. Sure you could use it in production but that was not the original intent.

In general I would agree that logging a simple warning would suffice, regardless of whether fatal_deprecation=true is set. This is however a general problem and not just related to these flags. Given that we are removing so many options (which were silently deprecated) I don't see any harm in re-adding them. What I'm getting at is... this is probably going to break someone because we were in stealth deprecation mode here...

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on nova (master)

Change abandoned by Sean Dague (<email address hidden>) on branch: master
Review: https://review.openstack.org/133212

Revision history for this message
OpenStack Infra (hudson-openstack) wrote :

Change abandoned by Sean Dague (<email address hidden>) on branch: master
Review: https://review.openstack.org/133213

Revision history for this message
OpenStack Infra (hudson-openstack) wrote :

Change abandoned by Sean Dague (<email address hidden>) on branch: master
Review: https://review.openstack.org/133214

Revision history for this message
OpenStack Infra (hudson-openstack) wrote :

Change abandoned by Sean Dague (<email address hidden>) on branch: master
Review: https://review.openstack.org/133215

Revision history for this message
Doug Hellmann (doug-hellmann) wrote :

We're tracking this in oslo.config with https://bugs.launchpad.net/oslo.config/+bug/1390408, which more clearly states in the bug description what we need to do.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers