devtest_seed.sh failed ,"Timing out after 300 seconds"

Bug #1387961 reported by jiangfei on 2014-10-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Undecided
jiangfei

Bug Description

when I run devtest_seed.sh in HOST( fedora 19) failed .

the message is :
Waiting for nova to initialise...
+ wait_for 50 10 nova list
+ user-config
+ echo 'Waiting for Nova Compute to be available'
Waiting for Nova Compute to be available
+ wait_for 30 10 nova service-list --binary nova-compute '2>/dev/null' '|' grep 'enabled.*\ up\ '
Timing out after 300 seconds:
COMMAND=nova service-list --binary nova-compute 2>/dev/null | grep enabled.*\ up\
OUTPUT=

when I login the VM use ssh, I found the nova-compute process is start, but it doesn't work.

[stack@localhost ~]$ ps -ef |grep nova-compute
nova 4171 1 0 19:34 ? 00:00:00 /opt/stack/venvs/nova/bin/python /opt/stack/venvs/nova/bin/nova-compute --config-dir /etc/nova --config-dir /etc/nova/compute
stack 4794 4764 0 19:36 pts/0 00:00:00 grep --color=auto nova-compute

and there is no nova-compute service register to the nova-services.
[stack@localhost ~]$ nova service-list
+----+------------------+------+----------+---------+-------+----------------------------+-----------------+
| Id | Binary | Host | Zone | Status | State | Updated_at | Disabled Reason |
+----+------------------+------+----------+---------+-------+----------------------------+-----------------+
| 1 | nova-conductor | seed | internal | enabled | up | 2014-10-31T19:37:12.000000 | - |
| 2 | nova-cert | seed | internal | enabled | up | 2014-10-31T19:37:12.000000 | - |
| 3 | nova-scheduler | seed | internal | enabled | up | 2014-10-31T19:37:12.000000 | - |
| 4 | nova-consoleauth | seed | internal | enabled | up | 2014-10-31T19:37:12.000000 | - |
+----+------------------+------+----------+---------+-------+----------------------------+-----------------+

jiangfei (jiangfei0622) on 2014-10-31
Changed in tripleo:
assignee: nobody → jiangfei (jiangfei0622)
jiangfei (jiangfei0622) on 2014-10-31
summary: - devstack_seed.sh failed ,"Timing out after 300 seconds"
+ devtest_seed.sh failed ,"Timing out after 300 seconds"
Ben Nemec (bnemec) wrote :

A couple of things - first, Fedora 19 isn't supported for tripleo anymore. I strongly suggest you run on Fedora 20. Second, to know what happened we need the nova-compute logs.

Changed in tripleo:
status: New → Incomplete
jiangfei (jiangfei0622) wrote :

OK, I will run on Fedora 20, and test it again。 I have on question: everytime devtest use pip install is very slow,
I export the env like this:
export PYPI_MIRROR_URL=http://pypi.pubyun.com/simple/
export DIB_NO_PYPI_PIP=1

but it doesn't work,can you help me? thank you。

James Polley (tchaypo) wrote :

I've flagged this as invalid because it doesn't (yet) have anything we can investigate - please feel free to change it back once we've got the logs and something to look at.

The pypi issue could be any of several things - without knowing the exact error it's hard to pin down. I'd suggest jumping into #tripleo so we can walk through that with you.

Changed in tripleo:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers